Zum Inhalt wechseln


Foto

Postfächer umziehen Exchange 2010


  • Bitte melde dich an um zu Antworten
66 Antworten in diesem Thema

#1 sakoti

sakoti

    Board Veteran

  • 456 Beiträge

 

Geschrieben 28. Dezember 2012 - 08:40

Ich habe Probleme bei lokalen Verschiebungsanforderungen (Server 2008 R2, Exchange SP1 Version 14.02)

Eseutil hat festgestellt, dass die DB Probleme macht, also leg ich eine neue DB an und kann auch einige Postfächer ohne Probleme via lokaler Verschiebungsanforderung dorhin schieben; auch größere Postfäher mit 2-3 GB.
An der Größe liegen die Fehler also nicht.

Schaue ich dann ins Log bei einem fehlgeschlagenen Postfach, sehe ich, dass da auch schon z.B. 10 000 von 16 000 Nachrichten geklappt hätten und dann kommt es zum Fehler, der mir Rätsel aufgibt.

27.12.2012 16:53:26 [DE85399S001] Während des Verschiebungsvorgangs wurde ein ungültiges Element erkannt. Das Element wurde nicht in das Zielpostfach kopiert.
<baditem errorType="MapiExceptionMaxSubmissionExceeded" errorCode="0x80004005" flags="0x00000000" id="00000000B592E8C9490E71408B7659B338003EAB07001201AB15CB4B324A8391931AEF586C6800000000001F00001201AB15CB4B324A8391931AEF586C68000001D4EC560000">
  <folder id="00000000B592E8C9490E71408B7659B338003EAB01001201AB15CB4B324A8391931AEF586C6800000000001F0000">Posteingang</folder>
  <sender>XXXXX</sender>
  <recipient>YYYYY</recipient>
  <subject>Dokumente bei SAP </subject>
  <messageClass>IPM.Note</messageClass>
  <size>21819005</size>
  <dateSent>12/06/2011 18:10:49</dateSent>
  <dateReceived>12/06/2011 18:12:05</dateReceived>
  <errorMessage>Die Nachricht (Größe 20.81 MB (21,819,005 bytes)) überschreitet die maximale zulässige Nachrichtengröße zum Senden an das Zielpostfach. Sie können diesen Grenzwert mithilfe des Cmdlets 'Set-Mailbox' in der Exchange-Verwaltungsshell erhöhen.
Fehlerdetails: MapiExceptionMaxSubmissionExceeded: IExchangeFastTransferEx.TransferBuffer failed (hr=0x80004005, ec=1242)
Diagnostic context:

SetMailbox habe ich ausgeführt vor dem Verschiebungsvorgang und es gibt keinerlei Beschränkungen, was die Größe anbelangt.
Hat jemand eine Idee oder auch schon einmal Probleme gehabt in diesem Bereich?

Vielen Dank.
70-270, 70-640, 70-642
70-643, 70-646, 70-647
70-680

#2 RobertWi

RobertWi

    Expert Member

  • 4.987 Beiträge

 

Geschrieben 28. Dezember 2012 - 09:03

Moin,

wirf mal einen Blick in die Datei C:\Program Files\Microsoft\Exchange Server\V14\Bin\MSExchangeMailboxReplication.exe.config

Dort gibt es mehrfach Größenbegrenzungen.

WICHTIG: Vor Änderungen die Datei sichern und danach den Dienst Microsoft Exchange-Postfachreplikation neustarten

Und zur Sicherheit schau mal im Postfach nach, dass es dort nicht doch eine Größenbeschränkung gibt: Get-Mailbox XXXXX | fl *size*

Tipp: Zwei Stunden Try&Error können 10 Minuten lesen im Technet sparen!


#3 sakoti

sakoti

    Board Veteran

  • 456 Beiträge

 

Geschrieben 28. Dezember 2012 - 09:27

Moin moin,

danke für deine Antwort; die Größenbeschränkung kann ich später erst abfragen. Ich teste grad noch mit BadItemLimit 3000, evtl. wird das ja was.

Welche Werte sollte ich hier raufsetzen oder siehst du da was, was stört?

   <system.serviceModel>
    <bindings>
      <netTcpBinding>
        <binding name="MrsBinding" portSharingEnabled="true" maxReceivedMessageSize="262144" >
          <readerQuotas 
            maxStringContentLength="262144" />
          <security mode="Transport">
            <transport clientCredentialType="Windows" protectionLevel="EncryptAndSign" />
          </security>
        </binding>
      </netTcpBinding>
      <customBinding>
        <binding name="MrsProxyClientBinding" 
                 receiveTimeout="00:00:50" 
                 sendTimeout="00:00:50">
          <reliableSession ordered="true" />
          <textMessageEncoding>
            <readerQuotas maxArrayLength="1048576" 
                          maxStringContentLength="1048576" />
          </textMessageEncoding>
          <httpsTransport authenticationScheme="Negotiate" 
                          maxReceivedMessageSize="1048576" 
                          allowCookies="true" />
        </binding>
      </customBinding>
    </bindings>
    <services>
      <service name="Microsoft.Exchange.MailboxReplicationService.MailboxReplicationService"
               behaviorConfiguration="MrsServiceBehavior">
        <endpoint address="net.tcp://localhost/Microsoft.Exchange.MailboxReplicationService"
                  binding="netTcpBinding"
                  bindingConfiguration="MrsBinding" 
                  contract="Microsoft.Exchange.MailboxReplicationService.IMailboxReplicationService" />
      </service>
    </services>
    <behaviors>
      <serviceBehaviors>
        <behavior name="MrsServiceBehavior">
          <serviceDebug includeExceptionDetailInFaults="True" />
          <serviceAuthorization serviceAuthorizationManagerType="Microsoft.Exchange.MailboxReplicationService.MRSAuthorizationManager, Microsoft.Exchange.MailboxReplicationService, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        </behavior>
      </serviceBehaviors>
    </behaviors>
  </system.serviceModel>
  <!-- Mailbox Replication Service configuration 

    <MRSConfiguration 
    MaxRetries = "60"
    MaxCleanupRetries = "5"
    MaxStallRetryPeriod = "00:15:00"
    RetryDelay = "00:00:30"
    MaxMoveHistoryLength = "2" 
    MaxActiveMovesPerSourceMDB = "5"
    MaxActiveMovesPerTargetMDB = "2"
    MaxActiveMovesPerSourceServer = "50"
    MaxActiveMovesPerTargetServer = "5"
    MaxTotalMovesPerMRS = "100"
    FullScanMoveJobsPollingPeriod = "00:10:00"
    MinimumTimeBeforePickingJobsFromSameDatabase = "00:00:04"
    ServerCountsNotOlderThan = "00:10:00"
    MRSAbandonedMoveJobDetectionTime = "01:00:00"
    BackoffIntervalForProxyConnectionLimitReached = "00:30:00"
    DataGuaranteeCheckPeriod = "00:00:10"
    DataGuaranteeTimeout = "00:30:00"
    DataGuaranteeLogRollDelay = "00:01:00"
    EnableDataGuaranteeCheck = "true"
    DisableMrsProxyCompression = "false"
    DisableMrsProxyBuffering = "false"
    MinBatchSize = "100"
    MinBatchSizeKB = "256" />
</configuration>


Diese beiden sind wichtig oder?

maxReceivedMessageSize="262144" >
          <readerQuotas 
            maxStringContentLength="262144" />

70-270, 70-640, 70-642
70-643, 70-646, 70-647
70-680

#4 RobertWi

RobertWi

    Expert Member

  • 4.987 Beiträge

 

Geschrieben 28. Dezember 2012 - 09:30

Welche Werte das genau sind, kann ich Dir nicht sagen, weil ich es auch im Augenblick nicht ausprobieren kann.

Ich würde mit denen hier "spielen":

IMHO kann es wenig Schaden geben, die Werte einfach mal um den Faktor 10 zu erhöhen.


[quote name='shafner']Moin moin,

danke für deine Antwort; die Größenbeschränkung kann ich später erst abfragen. Ich teste grad noch mit BadItemLimit 3000, evtl. wird das ja was.

Welche Werte sollte ich hier raufsetzen oder siehst du da was, was stört?

   <system.serviceModel>
    <bindings>
      <netTcpBinding>
        <binding name="MrsBinding" portSharingEnabled="true" [COLOR="Red"]maxReceivedMessageSize="262144"[/COLOR] >
          <readerQuotas 
            [COLOR="red"]maxStringContentLength="262144"[/COLOR] />
          <security mode="Transport">
            <transport clientCredentialType="Windows" protectionLevel="EncryptAndSign" />
          </security>
        </binding>
      </netTcpBinding>
      <customBinding>
        <binding name="MrsProxyClientBinding" 
                 receiveTimeout="00:00:50" 
                 sendTimeout="00:00:50">
          <reliableSession ordered="true" />
          <textMessageEncoding>
            <readerQuotas [COLOR="red"]maxArrayLength="1048576"[/COLOR] 
                          [COLOR="red"]maxStringContentLength="1048576"[/COLOR] />
          </textMessageEncoding>
          <httpsTransport authenticationScheme="Negotiate" 
                          [COLOR="red"]maxReceivedMessageSize="1048576"[/COLOR] 
                          allowCookies="true" />
        </binding>
      </customBinding>
    </bindings>
    <services>
      <service name="Microsoft.Exchange.MailboxReplicationService.MailboxReplicationService"
               behaviorConfiguration="MrsServiceBehavior">
        <endpoint address="net.tcp://localhost/Microsoft.Exchange.MailboxReplicationService"
                  binding="netTcpBinding"
                  bindingConfiguration="MrsBinding" 
                  contract="Microsoft.Exchange.MailboxReplicationService.IMailboxReplicationService" />
      </service>
    </services>
    <behaviors>
      <serviceBehaviors>
        <behavior name="MrsServiceBehavior">
          <serviceDebug includeExceptionDetailInFaults="True" />
          <serviceAuthorization serviceAuthorizationManagerType="Microsoft.Exchange.MailboxReplicationService.MRSAuthorizationManager, Microsoft.Exchange.MailboxReplicationService, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        </behavior>
      </serviceBehaviors>
    </behaviors>
  </system.serviceModel>
  <!-- Mailbox Replication Service configuration 

    <MRSConfiguration 
    MaxRetries = "60"
    MaxCleanupRetries = "5"
    MaxStallRetryPeriod = "00:15:00"
    RetryDelay = "00:00:30"
    MaxMoveHistoryLength = "2" 
    MaxActiveMovesPerSourceMDB = "5"
    MaxActiveMovesPerTargetMDB = "2"
    MaxActiveMovesPerSourceServer = "50"
    MaxActiveMovesPerTargetServer = "5"
    MaxTotalMovesPerMRS = "100"
    FullScanMoveJobsPollingPeriod = "00:10:00"
    MinimumTimeBeforePickingJobsFromSameDatabase = "00:00:04"
    ServerCountsNotOlderThan = "00:10:00"
    MRSAbandonedMoveJobDetectionTime = "01:00:00"
    BackoffIntervalForProxyConnectionLimitReached = "00:30:00"
    DataGuaranteeCheckPeriod = "00:00:10"
    DataGuaranteeTimeout = "00:30:00"
    DataGuaranteeLogRollDelay = "00:01:00"
    EnableDataGuaranteeCheck = "true"
    DisableMrsProxyCompression = "false"
    DisableMrsProxyBuffering = "false"
    MinBatchSize = "100"
    MinBatchSizeKB = "256" />
</configuration>

Tipp: Zwei Stunden Try&Error können 10 Minuten lesen im Technet sparen!


#5 sakoti

sakoti

    Board Veteran

  • 456 Beiträge

 

Geschrieben 28. Dezember 2012 - 10:20

Dankeschön. Er macht jetzt weiter mit dem Verschieben. Über diese Stelle kam ich bislang noch nicht hinaus.

Der Befehl hier hat wohl geholfen, gebe nochmal Bescheid:

Set-MoveRequest -Identity Postfach -BadItemLimi 3000 -AcceptLargeDataLoss


70-270, 70-640, 70-642
70-643, 70-646, 70-647
70-680

#6 RobertWi

RobertWi

    Expert Member

  • 4.987 Beiträge

 

Geschrieben 28. Dezember 2012 - 10:22

Moin,

ich denke zwar, dass das nur das Symptom des Abbruches behebt, nicht aber die wirkliche Ursache, aber berichte mal, wieviele Mails der Anwender nach dem Umzug vermisst. ;)

Tipp: Zwei Stunden Try&Error können 10 Minuten lesen im Technet sparen!


#7 sakoti

sakoti

    Board Veteran

  • 456 Beiträge

 

Geschrieben 28. Dezember 2012 - 10:28

Das ist jetzt eh nur ein Test mit diesem Postfach. Werde im Anschluss die Werte in der config-Datei + Dienst restart auch noch machen. Schaden tut das nicht und lass dann auf meinem Testsystem noch n paar Postfächer über die Feiertage laufen.
70-270, 70-640, 70-642
70-643, 70-646, 70-647
70-680

#8 sakoti

sakoti

    Board Veteran

  • 456 Beiträge

 

Geschrieben 28. Dezember 2012 - 12:10

So, ich habe mal das Log angesehen, komme aber nicht 100% klar damit.

Sind die "regulär gelöschten Elemente" die sich im Papierkorb des Postfaches befinden oder?

Zu Beginn hatte ich etwas von 15096 Mails gelesen. Ich kann also davon ausgehen, dass es 2 Mails nicht geschafft haben oder? Das müssen eigentlich die beiden Mails sein, wenn ich mir die Fehler im Log ansehe, habe ich 2 Stellen, dass die Mail nicht ins Zielpostfach verschoben wurde. Wie kann ich so etwas handeln, dass derartige Mails auch verschoben werden bzw. herausfinden wieso diese nicht verschoben werden?

Gibt es eine Möglichkeit, sich im Detail anzeigen zu lassen, wenn Elemente aufgrund von Fehlern nicht verschoben wurden?

28.12.2012 12:00:16 [mail001] Die Verschiebung wurde abgeschlossen, und die abschließende Bereinigung wurde gestartet.
28.12.2012 12:00:16 [mail001] Zielpostfach 'Primär (cc05ad76-6e72-499b-a28c-2f547d66dda0)' wurde nach dem Verschieben erfolgreich zurückgesetzt.
28.12.2012 12:00:16 [mail001] Für den MBI-Cache der Datenbank von Zielpostfach 'Primär (cc05ad76-6e72-499b-a28c-2f547d66dda0)' wurde nach der Verschiebung erfolgreich ein Seeding durchgeführt. Wenn sich das Zielpostfach auf einem Postfachserver von Exchange 2003 oder Exchange 2007 befand, wird dieser Vorgang nicht unterstützt und wurde nicht durchgeführt.
28.12.2012 12:00:17 [mail001] Das Quellpostfach 'Primär (cc05ad76-6e72-499b-a28c-2f547d66dda0)' wurde nach dem Verschieben erfolgreich bereinigt.
28.12.2012 12:00:17 [mail001] Informationen des Zielpostfachs:
Reguläre Elemente: 15094, 2.617 GB (2,810,508,421 bytes)
Regulär gelöschte Elemente: 1116, 4.819 MB (5,053,183 bytes)
FAI-Elemente: 22, 0 B (0 bytes)
Gelöschte FAI-Elemente: 0, 0 B (0 bytes)
28.12.2012 12:00:17 [mail001] Die Anforderung ist abgeschlossen.


70-270, 70-640, 70-642
70-643, 70-646, 70-647
70-680

#9 sakoti

sakoti

    Board Veteran

  • 456 Beiträge

 

Geschrieben 28. Dezember 2012 - 12:26

Als Fehler wird immer eine zu große Nachricht angemeckert. Ich gehe wie folgt vor:

1.
Set-Mailbox -Identity mailbox -MaxSendSize unlimited

lokale Verschiebungsanforderung

2.
Set-MoveRequest -Identity mailbox -IgnoreRuleLimitErrors $true
3.
Set-MoveRequest -Identity mailbox -BadItemLimit 3000 -AcceptLargeDataLoss

Im Log steht dann bei den Nachrichten, die nicht verschoben werden:

28.12.2012 11:17:15 [DE85399S001] Während des Verschiebungsvorgangs wurde ein ungültiges Element erkannt. Das Element wurde nicht in das Zielpostfach kopiert.
<baditem errorType="MapiExceptionMaxSubmissionExceeded" errorCode="0x80004005" flags="0x00000000" id="00000000B592E8C9490E71408B7659B338003EAB07001201AB15CB4B324A8391931AEF586C6800000000001F00001201AB15CB4B324A8391931AEF586C68000001D4EC560000">
<folder id="00000000B592E8C9490E71408B7659B338003EAB01001201AB15CB4B324A8391931AEF586C6800000000001F0000">Posteingang</folder>
<sender>XXXX</sender>
<recipient>YYYY</recipient>
<subject>DBetreff </subject>
<messageClass>IPM.Note</messageClass>
<size>21819005</size>
<dateSent>12/06/2011 18:10:49</dateSent>
<dateReceived>12/06/2011 18:12:05</dateReceived>
<errorMessage>Die Nachricht (Größe 20.81 MB (21,819,005 bytes)) überschreitet die maximale zulässige Nachrichtengröße zum Senden an das Zielpostfach. Sie können diesen Grenzwert mithilfe des Cmdlets 'Set-Mailbox' in der Exchange-Verwaltungsshell erhöhen.
Fehlerdetails: MapiExceptionMaxSubmissionExceeded: IExchangeFastTransferEx.TransferBuffer failed (hr=0x80004005, ec=1242)
Diagnostic context:



Es gibt keinerlei Beschränkungen, was Nachrichten anbelangt oder ich bin echt ratlos, wo das noch einzustellen wäre. Die config-Datei hab ich geändert und den Mailbox-Replikationsdienst neugestartet...
70-270, 70-640, 70-642
70-643, 70-646, 70-647
70-680

#10 Vertigo08

Vertigo08

    Newbie

  • 63 Beiträge

 

Geschrieben 28. Dezember 2012 - 12:31

hallo,du musst die Transporteinstellungen , speziell den Wert maximale sendegröße abändern , standardmässig ist er auf 10 MB gesetzt.
Du solltest ein Wert über 25 MB einstellen.
Deswegen erscheintdie <errorMessage>Die Nachricht (Größe 20.81 MB (21,819,005 bytes)) überschreitet die maximale zulässige Nachrichtengröße zum Senden...

Organisationskonfiguration> Hub-Transport > Globale Einstellungen > Allgemein

oder per shell

Get-TransportConfig | FL MaxReceiveSize,MaxSendSize

Set-TransportConfig -MaxReceiveSize (Wert in KB!)
Set-TransportConfig -MaxSendSize (Wert in KB!)

hinterher sollten die Postfächer erlogreich verschoben werden!

#11 RobertWi

RobertWi

    Expert Member

  • 4.987 Beiträge

 

Geschrieben 28. Dezember 2012 - 12:38

Ja, probier mal aus - bin gespannt ob das was hilft.

Tipp: Zwei Stunden Try&Error können 10 Minuten lesen im Technet sparen!


#12 sakoti

sakoti

    Board Veteran

  • 456 Beiträge

 

Geschrieben 28. Dezember 2012 - 14:00

@vertigo08

Vielen Dank.
Ich teste das mal am Mittwoch ausführlich. Habe aber mal kurz im Livesystem geschaut, da stehen 20 000 drinnen.
Ich glaube das war schon die Rätsels Lösung.

Da hätte ich noch lange im Web suchen können und wohl nix gefunden. Danke nochmal und guten Rutsch. Geb dann nochmal bescheid, wenn ich es getestet hab.
70-270, 70-640, 70-642
70-643, 70-646, 70-647
70-680

#13 sakoti

sakoti

    Board Veteran

  • 456 Beiträge

 

Geschrieben 03. Januar 2013 - 07:33

Hallo nochmal.

Mit dieser Option klappt es ohne Fehler. Habe einige Postfächer auf dem Testsystem umziehen können.

 

Gehe wie folgt vor:

1. Die Einstellung von Vertigo08

2. An der neuen Datenbank selbst die Größenbeschränkungen für Postfächer raus, die drinnen sind

3. Set-Mailbox -Identity "alias" -MaxSendSize unlimited

4. Lokale Verschiebungsanforderung

 

Mitunter behebt diese Einstellung auch die Probleme, die ich an der Remote Verschiebung hatte....?

In einem zweiten Step ist geplant einen eigenständigen DC in neuer Gesamtstruktur aufzusetzen mit Exchange und die Postfächer einer Datenbank dorthin zu migrieren. Wären beides Server 2008 R2 und Exchange die identische Version.


70-270, 70-640, 70-642
70-643, 70-646, 70-647
70-680

#14 sakoti

sakoti

    Board Veteran

  • 456 Beiträge

 

Geschrieben 09. Januar 2013 - 15:48

Was lokal so gut geklappt hat, funktioniert leider bei der remote verschiebung nicht :-(

Beider Server sind SRV2008 R2 und Exchange mit SP2 in identischer Versionierung.

 

- DNS - bedingte Weiterleitung auf beiden Servern

- Trust ist eingerichtet entsprechend

- Domänenadmin des einen Servers jeweils in der Admin Gruppe des anderen Servers

- Ping in beide Richtungen klappt (Servername, FQDN)

 

Habe mir diverse Anleitung zu Gemüte geführt zum remote move request, aber es klappt einfach nicht.

Gehe wie folgt vor:

 

- Prepare-moveRequest

- ADMT Tool

- Verschiebung via Exchange Management Konsole

 

dort erhalte ich entsprechend den Fehler

 

Die wichtige Eigenschaft "LegacyExchangeDN" fehlt im MailUser-Objekt

 

Gerne würde ich dem User auf dem Destination Server die Eigenschaft geben, aber ich weis nicht wie.

Bei der Remote Verschiebung via Management Konsole findet er bei durchsuchen auch keine Zielzustellungsdomäne. Diese habe ich manuell eingegeben, genau wie die Zieldatenbank. Eine Verbindung ist aber zweifelsohne vorhanden, da ich einmal eine Zieldatenbank eingegeben hatte, die es nicht gab am Zielsystem. Bei Eingabe von vorhandener DB bekomme ich den Fehler oben.

 

Hat jemand einen Rat? Vielen Dank.


70-270, 70-640, 70-642
70-643, 70-646, 70-647
70-680

#15 sakoti

sakoti

    Board Veteran

  • 456 Beiträge

 

Geschrieben 10. Januar 2013 - 08:27

Ich habe diese Fehlermeldung beheben können und habe jetzt einen anderen Fehler...

 

Ursache für die Meldung oben war:

Auf dem Ziel-Server unter den Mail-Kontakten die Anmeldung für das Konto auf die neue Domäne umstellen. Dort war unerklärlicherweise die Domain des Quell Servers drinnen.

 

Jetzt bekomme ich folgende Meldung bei der Remote-Verschiebung:

 

 

Fehler:
Fehler beim Aufruf von 'https://XXXX.local/EWS/mrsproxy.svc'. Fehlerdetails: Es konnte keine Vertrauensstellung für den sicheren SSL/TLS-Kanal mit Autorität XXXX.local eingerichtet werden. --> Die zugrunde liegende Verbindung wurde geschlossen: Für den geschützten SSL/TLS-Kanal konnte keine Vertrauensstellung hergestellt werden.. --> Das Remotezertifikat ist laut Validierungsverfahren ungültig..

Es konnte keine Vertrauensstellung für den sicheren SSL/TLS-Kanal mit Autorität XXXX.local eingerichtet werden.

Die zugrunde liegende Verbindung wurde geschlossen: Für den geschützten SSL/TLS-Kanal konnte keine Vertrauensstellung hergestellt werden..

Das Remotezertifikat ist laut Validierungsverfahren ungültig.
Hier klicken, um die Hilfe aufzurufen ... http://technet.micro...xch.err.default(EXCHG.140).aspx?v=14.2.247.1&t=exchgf1&e=ms.exch.err.Ex8FE8AA

Ausführungsversuch eines Exchange-Verwaltungsshellbefehls:
'0076dad4-a701-4816-b4a3-20e06f2dc0ac' | New-MoveRequest -Remote -TargetDatabase 'test' -RemoteHostName 'XXXX.local' -TargetDeliveryDomain 'BDF.local'


70-270, 70-640, 70-642
70-643, 70-646, 70-647
70-680