Zum Inhalt wechseln


Foto

SharePoint 2010 Seite akzeptiert login nicht


  • Bitte melde dich an um zu Antworten
8 Antworten in diesem Thema

#1 CD1983

CD1983

    Member

  • 201 Beiträge

 

Geschrieben 02. Juli 2012 - 19:49

Hallo,

ich habe ein komisches Problem auf einem SharePoint 2010 Foundation. Ich habe dort eine Websitesammlung angelegt und im IIS und DNS die URL Intranet konfiguriert.

Das hat heute Mittag eigentlich auch alles von meinem Client geklappt. Aber auf dem Server auf dem SharePoint läuft, kann ich mich einfach nicht an der Intranetseite anmelden. Egal ob ich meinen User nehme, der Sammlungsadmin ist oder den Administrator der sekundärer Admin ist, geht nichts, das Anmeldefenster kommt immer wieder. Von meinem Client klappts auch nicht.

Ich bin dann hingegangen und habe im IIS die Header Info im Binding entfernt und die DNS Einträge. Wenn ich dann die IP im IE aufrufe kann ich mich anmelden?!

Aber woran kann das liegen? Ich habe nichts geändert. Habe auch die beiden DCs und den SharePoint Server neu gestartet!?

Das ist aktuell noch eine Testumgebung, daher kann ich dort auch das ein odere andere machen.

Grüße

#2 Dukel

Dukel

    Board Veteran

  • 8.691 Beiträge

 

Geschrieben 02. Juli 2012 - 20:14

Im IIS sollst du die URL nicht konfigurieren. Das macht Sharepoint für dich.

Hast du als Authentifizierung NTLM oder Kerberos eingestellt?

Stop making stupid people famous.


#3 CD1983

CD1983

    Member

  • 201 Beiträge

 

Geschrieben 02. Juli 2012 - 20:51

Hi,

=)

Ich habe im IIS unter den Sites der SharePoint - 80 unter Bindung den Header "intranet" eingetragen. Das habe ich auf einer Schulung gesagt bekommen!?

Als Authentifizierung ist NTLM aktiv.

#4 Dukel

Dukel

    Board Veteran

  • 8.691 Beiträge

 

Geschrieben 02. Juli 2012 - 21:21

Hast du zu der Zeit als du dich einloggen wolltest in das ULS Log geschaut (geht am besten mit dem ULS Viewer)?

Beim anlegen von Sharepoint Webapplikationen wird normalerweise der Hostheader gesetzt.

Stop making stupid people famous.


#5 CD1983

CD1983

    Member

  • 201 Beiträge

 

Geschrieben 02. Juli 2012 - 21:47

Hi,

ne hab ich nicht kannte ich auch nicht.
Werde ich morgen mal machen und bescheid geben!

Danke schon mal soweit!

Grüße

#6 PowerShellAdmin

PowerShellAdmin

    Board Veteran

  • 967 Beiträge

 

Geschrieben 03. Juli 2012 - 09:07

Es ist ein bekanntes Problem, dass du dich auf dem SharePoint-Host nicht anmelden kannst.

DisableLoopbackcheck muss hier auf 1 gesetzt werden, danach das System neustarten.

SharePoint disable loopback check (DisableLoopbackCheck dword in registry) - Jeremy Taylor | Jeremy Taylor

Grüße Admin

PS: Generell sollte man wenig wie notwendig im IIS setzen, aber man muss auch beim SP2010 mitm IIS arbeiten - z.B. Bindings setzen auf die verschiedenne IPs oder Zertifikate.
Außerdem können zusätzliche Webanwendungen mit URL Rewriterules sinn machen (z.B. Interne IP https -> http, externe IP http-> https), und/oder bei forderungsbasierter Authentifizierung (z.B. über eine FBA DB) müssen die Provider etc. gesetzt werden.

#7 zahni

zahni

    Expert Member

  • 15.456 Beiträge

 

Geschrieben 03. Juli 2012 - 09:19

Bitte bei Sharepoint am IIS nichts "mit der Hand" konfigurieren. Es sei denn, man weis genau was man macht. Auch die Host-Header lassen sich in der Zentral-Administration einrichten.

-Zahni

Wen du nicht mit Können beeindrucken kannst, den verwirre mit Schwachsinn!


#8 CD1983

CD1983

    Member

  • 201 Beiträge

 

Geschrieben 03. Juli 2012 - 09:23

Hallo zusammen,

vielen Dank für die Infos. Ich habe den Hostheader und die DNS einträge aktuell entfernt und es läuft ohne Probleme.

Interssant ist nur das ich letzte Woche eine SharePoint Found Schulung hatte und wir das so gezeigt bekommen haben, zumindest bei der ersten Websitesammlung.

Aber ich werde versuchen alles über die ZA zu machen!
Danke

#9 CD1983

CD1983

    Member

  • 201 Beiträge

 

Geschrieben 03. Juli 2012 - 09:32

Hi zahni,

habe es eben in der ZA unter den "Alternativen Zugriffszuordnungen" eingerichetet. Funktioniert soweit alles die URL stimmt nun auch mit Intranet.

Hoffe das war so wie du es mit empfholen hast ?

Für Verbesserungen bin ich immer zu haben auch für Kritik.

Grüße