Zum Inhalt wechseln


Foto

Benutzerfotos in AD

Active Directory

  • Bitte melde dich an um zu Antworten
56 Antworten in diesem Thema

#46 Dathy

Dathy

    Newbie

  • 24 Beiträge

 

Geschrieben 11. November 2013 - 15:24

Nein :D

Ich meinte, dass ich das Foto von SharePoint in das AD verlinken möchte.

Und vom AD sollte sich das dann verteilen...



#47 NorbertFe

NorbertFe

    Expert Member

  • 30.934 Beiträge

 

Geschrieben 11. November 2013 - 15:29

Also SharePoint kann das vom AD aus rübersynchen soweit ich mich erinnere ob "verlinken" geht, weiß ich nicht. Solltest nur die Richtung berücksichtigen, damit nicht jeder der Meinung ist, sein "my site" Foto ins AD zu pumpen.

Bye
Norbert

Make something i***-proof and they will build a better i***.


#48 Dathy

Dathy

    Newbie

  • 24 Beiträge

 

Geschrieben 11. November 2013 - 15:32

Das ist ja das Problem...

Ich hatte es wie folgt vor:

  • Benutzer lädt sein Foto im Sharepoint hoch.
  • Sharepoint speichert es in die Datenbank.
  • Sharepoint verlinkt es im Userprofil.
  • Lync schaut ins Userprofil im ActiveDirectory und fügt es ein.
  • Outlook genau so.

Ist das so möglich?

 

Gruß Tim



#49 NorbertFe

NorbertFe

    Expert Member

  • 30.934 Beiträge

 

Geschrieben 11. November 2013 - 15:35

Na dann syncht halt SharePoint nach AD, das geht auch (geht auch bidirektional). Hat aber immer das Risiko, dass sich Kollegen lustige Fotos hochladen, was ggf. nicht gerade professionell wirken kann. In deiner Liste also folgende Reihenfolge:
1. Benutzer lädt sein Foto im Sharpoint hoch
2. SharePoint speichert es
3. SharePoint syncht nach Active Directory

fertig. Alle anderen Anwendungen wie Lync oder Outlook schauen ja nur im AD nach.

Bye
Norbert

PS: Vorher testen und nicht gleich global freischalten. ;)

Bearbeitet von NorbertFe, 11. November 2013 - 15:35.

Make something i***-proof and they will build a better i***.


#50 Dathy

Dathy

    Newbie

  • 24 Beiträge

 

Geschrieben 11. November 2013 - 15:41

Wie kann ich das denn verlinken?

Also wie muss ich wo was einstellen?

 

Tut mir leid aber bin noch ganz frisch aus der Ausbildung :D Ein kleines Küken :)



#51 NorbertFe

NorbertFe

    Expert Member

  • 30.934 Beiträge

 

Geschrieben 11. November 2013 - 15:52

Und da hat man das googlen nicht gelernt oder schon wieder verlernt?
http://blogs.technet...k-and-lync.aspx

Bye
Norbert

Make something i***-proof and they will build a better i***.


#52 Dathy

Dathy

    Newbie

  • 24 Beiträge

 

Geschrieben 11. November 2013 - 15:56

Doch aber nicht das Richtige gefunden :p

Danke :)

 

Schönen Feierabend wünsche ich noch.

 

Tim



#53 Doso

Doso

    Board Veteran

  • 2.505 Beiträge

 

Geschrieben 11. November 2013 - 18:18

Nein, du kannst da nix verlinken. Was du machen kannst ist eine User Profil Synchronisierung einreichten. Das also aus dem Sharepoint in das das AD die Bilder synchronisiert werden, oder anders rum. Die Synchronisierung läuft üblicherweise einmal pro Nacht. Zum Thema gibt es genug im Technet/Intranet. Aber gleich mal zur Warnung: das Thema User Profile Sync ist komplex, das macht man nicht "einfach mal so".



#54 Dathy

Dathy

    Newbie

  • 24 Beiträge

 

Geschrieben 13. November 2013 - 07:28

Habe es jetzt mit ThumbnailPhoto ausprobiert und das klappt natürlich super.

Das Thema mit dem Sharepoint -> AD Sync hat leider nicht so geklappt wie ich es wollte. Alles genau so gemacht wie es auf den ganzen Technetseiten stand.

Auch alle Schritte im adsi editor eingestellt, rechte verteilt und dabei sogar versucht mit vollen Rechten.

Geklappt hat dies leider nicht.

 

Eine Ahnung woran das noch liegen könnte, habt ihr auch nicht oder?

 

Gruß Tim



#55 NorbertFe

NorbertFe

    Expert Member

  • 30.934 Beiträge

 

Geschrieben 13. November 2013 - 08:48

Nein, aber du bist ja noch neu und brauchst "Forschungsgebiete". Also Testumgebung aufbauen und los. ;)

Bye
Norbert

Make something i***-proof and they will build a better i***.


#56 Dathy

Dathy

    Newbie

  • 24 Beiträge

 

Geschrieben 13. November 2013 - 09:23

Ja...

Ich tu mein bestes :D

 

Danke aber schonmal.



#57 Doso

Doso

    Board Veteran

  • 2.505 Beiträge

 

Geschrieben 14. November 2013 - 16:31

Wie gesagt, das ist ein verdammt komplexes Thema. Da gibt es so viele Sachen an denen es liegen könnte  - und bei jedem Update von Sharepoint 2010 bastelt Microsoft daran rum.

 

Ich fand die Artikel von harbar.net recht informativ - viele der Technet Artikel basieren darauf z.B. http://www.harbar.ne.../sp2010ups.aspx





Auch mit einem oder mehreren der folgenden Tags versehen: Active Directory