Zum Inhalt wechseln


Foto

Probleme beim Versand von E-Mails (Ex 2007)


  • Bitte melde dich an um zu Antworten
51 Antworten in diesem Thema

#46 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 02. Februar 2010 - 08:47

Poste hier mal noch bitte den Wert der Attribute HomeMTA, HomeMDB und LegacyExchangeDN der System Attendant Mailbox

Navigiere mit Adsiedit.msc in folgenden Container
CN=Configuration, CN=Services,CN=Microsoft Exchange,CN=Organisation, CN=Administrative Groups, CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Servers,CN=DeinExchange

Rechtsklick auf CN=Microsoft System Attendant und die Werte der o.g. Attribute
MCT

#47 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 02. Februar 2010 - 08:56

Schön, dass du immer noch eine Idee in der Pipeline hast ;)

Hier die Werte:


homeMTA: CN=Microsoft MTA,CN=internerExchange2007,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=DOMAIN,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=DOMAIN,DC=lokal

homeMDB: CN=Mbox DB,CN=First Storage Group,CN=InformationStore,CN=internerExchange2007,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=DOMAIN,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=DOMAIN,DC=lokal

legacyExchangeDN: /o=DOMAIN/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=internerExchange2007/cn=Microsoft System Attendant



#48 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 02. Februar 2010 - 09:12

Sieht soweit mal vernünftig aus. Dann hab ich leider auch keine Idee mehr... Jetzt würde ich dir raten einen SupportCase bei Microsoft zu eröffnen
MCT

#49 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 02. Februar 2010 - 09:16

Das werd ich dann wohl tun müssen.

Mal so als Vorbereitung für den Call:

Sollte ich die Postfächer alle in einer Speichergruppe haben? Ich habe ja heute Nacht noch versucht zu testen, ob es an der Speichergruppe liegt und nur ca. 1 Dutzend Postfächer von Datenbank 2 (Speichergruppe 1) zu Datenbank 3 (in Speichergruppe 2) verschoben.

Reicht es auch aus, dass ich die Datenbank 1 in der Verwaltungskonsole "entfernt" habe oder sollte ich die unter C:\Programme\Microsoft(...) auch noch händisch löschen?

#50 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 02. Februar 2010 - 09:27

Sollte ich die Postfächer alle in einer Speichergruppe haben? Ich habe ja heute Nacht noch versucht zu testen, ob es an der Speichergruppe liegt und nur ca. 1 Dutzend Postfächer von Datenbank 2 (Speichergruppe 1) zu Datenbank 3 (in Speichergruppe 2) verschoben.

Das ist egal, so wie es aussieht hast du ja nur Probleme mit der System Attendant Mailbox - und die liegt ja in der Datenbank mit dem Namen CN=Mbox DB (HomeMDB Attribut).

Reicht es auch aus, dass ich die Datenbank 1 in der Verwaltungskonsole "entfernt" habe oder sollte ich die unter C:\Programme\Microsoft(...) auch noch händisch löschen?

Ja das reicht, sobald du die DB aus der Varwaltungskonsole entfernst, sind auch alle Verweise auf diese weg. Um Platz zu schaffen kannst du die DB aus dem Filesystem ebenfalls noch löschen - die wird ja eh nicht mehr verwendet ;)
MCT

#51 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 02. Februar 2010 - 09:45

Folgenden Fehler:

Ereignistyp: Fehler
Ereignisquelle: EXOLEDB
Ereigniskategorie: Allgemein
Ereigniskennung: 111
Datum: 30.01.2010
Zeit: 18:38:38
Benutzer: Nicht zutreffend
Computer: interner Exchange 2007
Beschreibung:
Microsoft Exchange OLEDB konnte bei MDB-Start Schemaweitergabe nicht durchführen. HRESULT = 0x80040e19


konnte ich übrigens über die Exchange Verwaltungsshell beheben:

set-publicfolder -identity "\non_ipm_subtree\schema-root" -name "schema"



#52 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 05. Februar 2010 - 09:34

Das Problem konnte leider nicht mit dem Microsoft-Support behoben werden, da lt. MS-Mitarbeiter auch kein technisches Problem vorliegt => Das Problem löst sich lt. Ereignisprotokoll offenbar von selbst. :suspect:

Hier noch einmal das Problem:

Ereignistyp: Fehler
Ereignisquelle: MSExchange System Attendant Mailbox
Ereigniskategorie: Allgemein
Ereigniskennung: 4001
Datum: 05.02.2010
Zeit: 10:05:27
Benutzer: Nicht zutreffend
Computer: internerExchange2007
Beschreibung:
Vorübergehender Fehler. Das Problem löst sich möglicherweise später von selbst. Der Dienst versucht es in 56 Sekunden erneut. Diagnoseinformationen:

Das Postfach /o=firma-abc/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=internerExchange2007/cn=Microsoft System Attendant kann nicht geöffnet werden.
Microsoft.Exchange.Data.Storage.ConnectionFailedTransientException: Das Postfach /o=firma-abc/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=internerExchange2007/cn=Microsoft System Attendant kann nicht geöffnet werden. ---> Microsoft.Mapi.MapiExceptionNetworkError: MapiExceptionNetworkError: Unable to make connection to the server. (hr=0x80040115, ec=-2147221227)
Diagnostic context:
......
(...)

Lid: 19778
Lid: 27970 StoreEc: 0x80040115
Lid: 17730
Lid: 25922 StoreEc: 0x80040115
bei Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, Int32 ec, DiagnosticContext diagCtx)

(...)

bei Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)
--- Ende der internen Ausnahmestapelüberwachung ---
bei Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)

(...)
bei Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString)
bei Microsoft.Exchange.Data.Storage.MailboxSession.Initialize(LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags)
bei Microsoft.Exchange.Data.Storage.MailboxSession.CreateMailboxSession(LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags, CultureInfo cultureInfo, String clientInfoString)
bei Microsoft.Exchange.Data.Storage.MailboxSession.OpenAsAdmin(ExchangePrincipal mailboxOwner, CultureInfo cultureInfo, String clientInfoString, Boolean useLocalRpc, Boolean ignoreHomeMdb)
bei Microsoft.Exchange.Data.Storage.MailboxSession.OpenAsAdmin(ExchangePrincipal mailboxOwner, CultureInfo cultureInfo, String clientInfoString)
bei Microsoft.Exchange.Servicelets.SystemAttendantMailbox.Servicelet.Work()


und hier die selbständige Lösung!?

Ereignistyp: Informationen
Ereignisquelle: MSExchange System Attendant Mailbox
Ereigniskategorie: Allgemein
Ereigniskennung: 4016
Datum: 05.02.2010
Zeit: 10:06:29
Benutzer: Nicht zutreffend
Computer: internerExchange2007
Beschreibung:
Die Anmeldung bei dem 'Posteingang' des Postfachs der Systemaufsicht war erfolgreich.


So wirklich zufriedenstellend ist das aber nicht, da ich leider nun immer noch nicht weiß, warum das Event 4001 überhaupt dokumentiert wird! :(