Zum Inhalt wechseln


Foto

Probleme beim Versand von E-Mails (Ex 2007)


  • Bitte melde dich an um zu Antworten
51 Antworten in diesem Thema

#31 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 31. Januar 2010 - 13:59

EdgeSubscription neu erstellt... Dienst neu gestartet => alles paletti. Mal gucken, wie lange das so bleibt...


Zum Event 4001 MSExchange System Attendant Mailbox könntest du mal folgendes versuchen:

Erstelle einen neuen Postfachspeicher, verschiebe alle Mailboxen dort rein und lösche den Ursprungs-Store.



Wenn ich einen neuen Store erstellen möchte, erscheint folgende Fehlermeldung:



Zusammenfassung: 2 Element(e). Erfolgreich: 1, Fehler: 1.
Verstrichene Zeit: 00:00:02


Neue®/(s) Mailbox Datenbank
Abgeschlossen

Ausführung eines Exchange-Verwaltungsshellbefehls abgeschlossen:
new-mailboxdatabase -StorageGroup 'internerExchange2007\First Storage Group' -Name 'Mailbox Datenbank' -EdbFilePath 'C:\Programme\Microsoft\Exchange Server\Mailbox\First Storage Group\Mailbox Datenbank.edb'

Verstrichene Zeit: 00:00:01


Mailbox Datenbank bereitstellen
Fehler

Fehler:
Exchange kann die angegebene Datenbank nicht bereitstellen. Angegebene Datenbank: internerExchange2007\First Storage Group\Mailbox Datenbank; Fehlercode: MapiExceptionADNotFound: Unable to mount database. (hr=0x80004005, ec=2417)
.

Ausführungsversuch eines Exchange-Verwaltungsshellbefehls:
mount-database -Identity 'CN=Mailbox Datenbank,CN=First Storage Group,CN=InformationStore,CN=internerExchange2007,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF89ACRLT),CN=Administrative Groups,CN=spdie,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=spdie,DC=lokal'


Im Ereignisprotokoll wird nichts dokumentiert. Auch das Erstellen einer neuen Speichergruppe und anschließend einer neuen Postfachdatenbank misslang. :(


Edit: Nach einem Neustart des Systems klappt es nun! :)

Bearbeitet von martins, 31. Januar 2010 - 14:17.


#32 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 31. Januar 2010 - 15:46

Also nach 1,5 Std. sind erst 5 von 84 Postfächern verschoben. Und wirklich groß sind die nicht, vielleicht so ca. 700 MB pro Postfach.

Ist das "normal" dass das Verschieben sooooo lange dauert? Sind zwar nur SATA-Disks (Raid 10), aber dass das so lahm ist...

#33 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 31. Januar 2010 - 16:00

Ja, je nach Hardwareausstattung kann das schon eine ganze Weile dauern.
Wichtig beim Verschieben: Achte auf deine Transaktionsprotokolle - Die können dir ganz schnell die Platte voll laufen lassen.

Notfalls stelle Circular Logging (Umlaufprotokollierung) für die Speichergruppen an.
MCT

#34 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 31. Januar 2010 - 16:10

Notfalls stelle Circular Logging (Umlaufprotokollierung) für die Speichergruppen an.


Jetzt während des Kopiervorgangs? Schließlich müsste ich ja dann den Informationsspeicher neu starten!?

#35 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 31. Januar 2010 - 16:21

Jetzt während des Kopiervorgangs? Schließlich müsste ich ja dann den Informationsspeicher neu starten!?


Ich kenne deine Plattenkapazität ja nicht. Im schlimmstenfall breche den Move-Vorgang ab, aktiviere die Umlaufprotokollierung, starte den Informationstore neu und wiederhole den Vorgang für die verbleibenden Postfächer.
Immernoch besser als eine mit Logs vollgelaufene Disk!
MCT

#36 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 31. Januar 2010 - 16:31

ich hab noch 300 GB frei - die DB ist rund 50 GB groß.

#37 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 31. Januar 2010 - 16:38

ich hab noch 300 GB frei - die DB ist rund 50 GB groß.


Könnte ausreichen, behalte den freien Speicher einfach im Auge ;)
MCT

#38 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 31. Januar 2010 - 16:49

Die Benutzer werden morgen keine Probleme mit Ihren Postfächern haben, wenn die Postfächer noch verschoben werden?

#39 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 31. Januar 2010 - 16:56

Die Benutzer werden morgen keine Probleme mit Ihren Postfächern haben, wenn die Postfächer noch verschoben werden?


Postfächer die bereits verschoben sind - nein. Der User/Outlook findet automatisch sein Postfach in der neuen Datenbank.

Auf Postfächer die sich gerade im Move-Vorgang befinden kann ein User nicht zugreifen. Die Mailbox ist für diesen Zeitraum "locked"
MCT

#40 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 31. Januar 2010 - 17:00

(...) Auf Postfächer die sich gerade im Move-Vorgang befinden kann ein User nicht zugreifen. Die Mailbox ist für diesen Zeitraum "locked"

Das wäre gar nicht gut - vor allem wenn es das Postfach des Chefs betrifft oder die Postfächer der Frühschicht. Ich könnte doch das Kopieren heute Nacht irgendwann abbrechen und dann in den nächsten 2 Nächten das Kopieren der dann noch verbleibenden Postfächer für rund 8 Stunden fortsetzen!? Spricht was dagegen? Muss ich noch auf andere evtl. anfallende Sachen achten (z. B. Öffentliche Ordner, etc.)?

#41 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 31. Januar 2010 - 17:09

Ich könnte doch das Kopieren heute Nacht irgendwann abbrechen und dann in den nächsten 2 Nächten das Kopieren der dann noch verbleibenden Postfächer für rund 8 Stunden fortsetzen!? Spricht was dagegen?

Das könntest du machen - da würde nichts dagegen sprechen. Prüfe am besten noch ob die "neue Datenbank" mit ins Backup aufgenommen wurde - bzw. setze das Backup aus

Muss ich noch auf andere evtl. anfallende Sachen achten (z. B. Öffentliche Ordner, etc.)?


Prüfe zur Sicherheit noch, ob in den Eigenschaften der neuen MailDB die Öffentliche Ordner DB eingetragen ist. Sollte im Normalfall aber passen ;)
MCT

#42 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 31. Januar 2010 - 17:53

Das könntest du machen - da würde nichts dagegen sprechen. Prüfe am besten noch ob die "neue Datenbank" mit ins Backup aufgenommen wurde - bzw. setze das Backup aus


Das hab ich schon gemacht. :)


Prüfe zur Sicherheit noch, ob in den Eigenschaften der neuen MailDB die Öffentliche Ordner DB eingetragen ist. Sollte im Normalfall aber passen ;)


Ist der gleiche Pfad eingetragen, wie in der ersten Datenbank. Insofern sollte es passen.

Ich warte jetzt einfach mal ab und gucke. 1/7 ist bereits kopiert.

... to be continued... ;)

#43 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 02. Februar 2010 - 07:52

nächste Runde... ;)

Zum Event 4001 MSExchange System Attendant Mailbox könntest du mal folgendes versuchen:

Erstelle einen neuen Postfachspeicher, verschiebe alle Mailboxen dort rein und lösche den Ursprungs-Store.


Es hat leider nichts gebracht. Ich habe den Postfachspeicher erstellt, die Postfächer verschoben, Bereitstellung der Datenbank aufgehoben und alte DB gelöscht. Neustart des Dienstes "MSExchangeSA" => Event 4001 :mad:

Macht es Sinn, dass ich den ganzen Zauber noch einmal mit einer neuen Speichergruppe versuche? :rolleyes:


Hier noch mal der Fehler im Detail:

Ereignistyp: Fehler
Ereignisquelle: MSExchange System Attendant Mailbox
Ereigniskategorie: Allgemein
Ereigniskennung: 4001
Datum: 02.02.2010
Zeit: 08:26:16
Benutzer: Nicht zutreffend
Computer: internerExchange2007
Beschreibung:
Vorübergehender Fehler. Das Problem löst sich möglicherweise später von selbst. Der Dienst versucht es in 56 Sekunden erneut. Diagnoseinformationen:

Das Postfach /o=domain/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=internerExchange2007/cn=Microsoft System Attendant kann nicht geöffnet werden.
Microsoft.Exchange.Data.Storage.ConnectionFailedTransientException: Das Postfach /o=domain/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=internerExchange2007/cn=Microsoft System Attendant kann nicht geöffnet werden. ---> Microsoft.Mapi.MapiExceptionNetworkError: MapiExceptionNetworkError: Unable to make connection to the server. (hr=0x80040115, ec=-2147221227)
Diagnostic context:
......
Lid: 10648 dwParam: 0x6D9 Msg: EEInfo: Generating component: 2
Lid: 14744 dwParam: 0x6D9 Msg: EEInfo: Status: 1753
Lid: 9624 dwParam: 0x6D9 Msg: EEInfo: Detection location: 501
Lid: 13720 dwParam: 0x6D9 Msg: EEInfo: Flags: 0
Lid: 11672 dwParam: 0x6D9 Msg: EEInfo: NumberOfParameters: 4
Lid: 8856 dwParam: 0x6D9 Msg: EEInfo: prm[0]: Unicode string: ncacn_ip_tcp
Lid: 8856 dwParam: 0x6D9 Msg: EEInfo: prm[1]: Unicode string: internerExchange2007.domain.lokal
Lid: 12952 dwParam: 0x6D9 Msg: EEInfo: prm[2]: Long val: -1527653632
Lid: 15000 dwParam: 0x6D9 Msg: EEInfo: prm[3]: Pointer val: 0x00000000035662B0
Lid: 19778
Lid: 27970 StoreEc: 0x80040115
Lid: 17730
Lid: 25922 StoreEc: 0x80040115
bei Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, Int32 ec, DiagnosticContext diagCtx)
bei Microsoft.Mapi.ExRpcConnection.Create(ConnectionCache connectionCache, ExRpcConnectionCreateFlag createFlags, ConnectFlag connectFlags, String serverDn, String userDn, String user, String domain, String password, String httpProxyServerName, Int32 ulConMod, Int32 lcidString, Int32 lcidSort, Int32 cpid, Int32 cReconnectIntervalInMins, Int32 cbRpcBufferSize, Int32 cbAuxBufferSize)
bei Microsoft.Mapi.ConnectionCache.OpenMapiStore(String mailboxDn, Guid mailboxGuid, Guid mdbGuid, ClientIdentityInfo clientIdentity, String userDnAs, OpenStoreFlag openStoreFlags, CultureInfo cultureInfo, String applicationId)
bei Microsoft.Mapi.ConnectionCache.OpenMailbox(String mailboxDn, Guid mailboxGuid, Guid mdbGuid, WindowsIdentity windowsIdentityAs, String userDnAs, OpenStoreFlag openStoreFlags, CultureInfo cultureInfo, String applicationId)
bei Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)
--- Ende der internen Ausnahmestapelüberwachung ---


(...)

#44 martins

martins

    Board Veteran

  • 1.034 Beiträge

 

Geschrieben 02. Februar 2010 - 07:52

(...)

bei Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)
bei Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)
bei Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString)
bei Microsoft.Exchange.Data.Storage.MailboxSession.Initialize(LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags)
bei Microsoft.Exchange.Data.Storage.MailboxSession.CreateMailboxSession(LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags, CultureInfo cultureInfo, String clientInfoString)
bei Microsoft.Exchange.Data.Storage.MailboxSession.OpenAsAdmin(ExchangePrincipal mailboxOwner, CultureInfo cultureInfo, String clientInfoString, Boolean useLocalRpc, Boolean ignoreHomeMdb)
bei Microsoft.Exchange.Data.Storage.MailboxSession.OpenAsAdmin(ExchangePrincipal mailboxOwner, CultureInfo cultureInfo, String clientInfoString)
bei Microsoft.Exchange.Servicelets.SystemAttendantMailbox.Servicelet.Work()

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter Events and Errors Message Center: Basic Search.



#45 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 02. Februar 2010 - 08:24

Eine Idee hab ich noch ;)

0x80040115 bedeutet MAPI_E_NETWORK_ERROR. Da deinen Schilderungen zu folge der Event 4001 nur nach einem Neustart protokolliert wird vermute ich daher ein Timing-Problem.
So dass der MSExchangeSA einfach zu früh startet, während andere Betriebssystemteile (wie z.B. Netzwerk o.ä.) noch nicht vollständig bereit sind.

Konfiguriere mal gemäß folgendem Artikel (Methode 3) eine Bootpause für den MSExchangeSA.

Services for Exchange Server 2007 or Exchange Server 2010 cannot start automatically after you install Exchange Server 2007 and Exchange Server 2010 on a global catalog server

Andere Ideen habe ich dazu nun leider auch nicht mehr.
MCT