Zum Inhalt wechseln


Foto

Update 9.1.1 von Adobe bereitgestellt


  • Bitte melde dich an um zu Antworten
47 Antworten in diesem Thema

#16 sdieterle

sdieterle

    Gast

  • 7 Beiträge

 

Geschrieben 21. August 2009 - 18:37

=== Verbose logging started: 21.08.2009 20:33:26 Build type: SHIP UNICODE 4.05.6001.00 Calling process: C:\WINXP\system32\msiexec.exe ===
MSI © (34:38) [20:33:26:140]: Resetting cached policy values
MSI © (34:38) [20:33:26:140]: Machine policy value 'Debug' is 0
MSI © (34:38) [20:33:26:140]: ******* RunEngine:
******* Product: AdbeRdr910_de_DE.msi
******* Action: ADMIN
******* CommandLine: **********
MSI © (34:38) [20:33:26:140]: Machine policy value 'DisableUserInstalls' is 0
MSI © (34:38) [20:33:27:000]: SOFTWARE RESTRICTION POLICY: Verifying package --> 'C:\temp\a913test2\AdbeRdr910_de_DE.msi' against software restriction policy
MSI © (34:38) [20:33:27:000]: SOFTWARE RESTRICTION POLICY: C:\temp\a913test2\AdbeRdr910_de_DE.msi has a digital signature
MSI © (34:38) [20:33:27:328]: SOFTWARE RESTRICTION POLICY: C:\temp\a913test2\AdbeRdr910_de_DE.msi is permitted to run at the 'unrestricted' authorization level.
MSI © (34:38) [20:33:27:328]: Cloaking enabled.
MSI © (34:38) [20:33:27:328]: Attempting to enable all disabled privileges before calling Install on Server
MSI © (34:38) [20:33:27:343]: End dialog not enabled
MSI © (34:38) [20:33:27:343]: Original package ==> C:\temp\a913test2\AdbeRdr910_de_DE.msi
MSI © (34:38) [20:33:27:343]: Package we're running from ==> C:\Users\ADMINI~1\LOKALE~1\Temp\439525.msi
MSI © (34:38) [20:33:27:343]: APPCOMPAT: looking for appcompat database entry with ProductCode '{AC76BA86-7AD7-1031-7B44-A91000000001}'.
MSI © (34:38) [20:33:27:343]: APPCOMPAT: no matching ProductCode found in database.
MSI © (34:38) [20:33:27:343]: MSCOREE not loaded loading copy from system32
MSI © (34:38) [20:33:27:343]: Machine policy value 'TransformsSecure' is 0
MSI © (34:38) [20:33:27:343]: User policy value 'TransformsAtSource' is 0
MSI © (34:38) [20:33:27:359]: Original patch ==> C:\temp\a913test2\AdbeRdrUpd913_all_incr.msp
MSI © (34:38) [20:33:27:359]: Patch we're running from ==> C:\Users\ADMINI~1\LOKALE~1\Temp\439526.msp
MSI © (34:38) [20:33:27:359]: SOFTWARE RESTRICTION POLICY: Verifying patch --> 'C:\temp\a913test2\AdbeRdrUpd913_all_incr.msp' against software restriction policy
MSI © (34:38) [20:33:27:359]: SOFTWARE RESTRICTION POLICY: C:\temp\a913test2\AdbeRdrUpd913_all_incr.msp has a digital signature
MSI © (34:38) [20:33:27:375]: SOFTWARE RESTRICTION POLICY: C:\temp\a913test2\AdbeRdrUpd913_all_incr.msp is permitted to run at the 'unrestricted' authorization level.
MSI © (34:38) [20:33:27:375]: SequencePatches starts. Product code: {AC76BA86-7AD7-1031-7B44-A91000000001}, Product version: 9.1.0, Upgrade code: {A6EADE66-0000-0000-484E-7E8A45000000}, Product language 1031
MSI © (34:38) [20:33:27:375]: PATCH SEQUENCER: verifying the applicability of minor upgrade patch C:\temp\a913test2\AdbeRdrUpd913_all_incr.msp against product code: {AC76BA86-7AD7-1031-7B44-A91000000001}, product version: 9.1.0, product language 1031 and upgrade code: {A6EADE66-0000-0000-484E-7E8A45000000}
MSI © (34:38) [20:33:27:375]: PATCH SEQUENCER: minor upgrade patch C:\temp\a913test2\AdbeRdrUpd913_all_incr.msp is not applicable.
MSI © (34:38) [20:33:27:375]: SequencePatches returns success.
MSI © (34:38) [20:33:27:375]: Final Patch Application Order:
MSI © (34:38) [20:33:27:375]: Other Patches:
MSI © (34:38) [20:33:27:375]: Unknown\Absent: {AC76BA86-7AD7-0000-2550-7A8C40000913} - C:\temp\a913test2\AdbeRdrUpd913_all_incr.msp
Das Updatepatch kann nicht vom Windows-Installationsdienst installiert werden, da das zu aktualisierende Programm nicht vorhanden ist oder eine andere Version des Programms mit dem Patch aktualisiert wird. Überprüfen Sie, ob das zu aktualisierende Programm vorhanden ist und das richtige Updatepatch verwendet wird.

#17 sdieterle

sdieterle

    Gast

  • 7 Beiträge

 

Geschrieben 21. August 2009 - 18:38

Das Updatepatch kann nicht vom Windows-Installationsdienst installiert werden, da das zu aktualisierende Programm nicht vorhanden ist oder eine andere Version des Programms mit dem Patch aktualisiert wird. Überprüfen Sie, ob das zu aktualisierende Programm vorhanden ist und das richtige Updatepatch verwendet wird.
C:\temp\a913test2\AdbeRdr910_de_DE.msi
MSI © (34:38) [20:33:27:375]: Produkt: Adobe Reader 9.1 - Deutsch - Update "{AC76BA86-7AD7-0000-2550-7A8C40000913}" konnte nicht installiert werden. Fehlercode 1642. Weitere Informationen sind in der Protokolldatei C:\temp\a913test2\log1.log enthalten.

MSI © (34:38) [20:33:27:375]: Ein Update wurde durch Windows Installer installiert. Produktname: Adobe Reader 9.1 - Deutsch. Produktversion: 9.1.0. Produktsprache: 1031. Updatename: {AC76BA86-7AD7-0000-2550-7A8C40000913}. Erfolg- bzw. Fehlerstatus der Installation: 1642.

MSI © (34:38) [20:33:27:375]: Note: 1: 1708
MSI © (34:38) [20:33:27:375]: Produkt: Adobe Reader 9.1 - Deutsch -- Installation fehlgeschlagen.

MSI © (34:38) [20:33:27:375]: Das Produkt wurde durch Windows Installer installiert. Produktname: Adobe Reader 9.1 - Deutsch. Produktversion: 9.1.0. Produktsprache: 1031. Erfolg- bzw. Fehlerstatus der Installation: 1642.

MSI © (34:38) [20:33:27:375]: Attempting to delete file C:\Users\ADMINI~1\LOKALE~1\Temp\439526.msp
MSI © (34:38) [20:33:27:390]: MainEngineThread is returning 1642
=== Verbose logging stopped: 21.08.2009 20:33:27 ===

#18 Sunny61

Sunny61

    Expert Member

  • 22.101 Beiträge

 

Geschrieben 21. August 2009 - 20:35

Lies doch bitte nochmal ganz genau: https://www.mcseboar...html#post956006
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#19 speedygonzales

speedygonzales

    Member

  • 166 Beiträge

 

Geschrieben 26. November 2010 - 12:32

msiexec /a C:\MeinTestOrdner\AdbeRdr910_de_DE.msi /p C:\MeinTestOrdner\AdbeRdrUpd913_all_incr.msp
Das ca. 45 MB große MSI-File jetzt noch in *913* umbenennen und schon kann es losgehen. ;)


ich habe es jetzt mit der 9.4.1 msp genau so gemacht, allerdings anstatt einer neue große MSI Datei wurde nur die alte 9.4.1 MSI um ein paar Bytes Geändert (die Datei ist nur 4 MB Gross), und es wurden 4 neue Unterverzeichnisse erstellt:

Windows\ 5.003.070
CommonAppData\ 479
program files\ 115.312.642
Common\ 6.282.238

wenn ich diese leicht veränderte MSI installiere wird tatsächlich die 9.4.1 verteilt?
Muss ich die neuen 4 Unterverzeichnisse auch auf dem Server kopieren? Bzw auch die msp?

Ich verstehe echt nicht, warum uns adobe immer das Leben schwer macht, die könnten doch 9.4.1 als msi bereitstellen

#20 zahni

zahni

    Expert Member

  • 16.390 Beiträge

 

Geschrieben 26. November 2010 - 12:35

Prüfe mal, ob die authplay.dll die Version 10,1,102,64 .

-Zahni

Wen du nicht mit Können beeindrucken kannst, den verwirre mit Schwachsinn!


#21 speedygonzales

speedygonzales

    Member

  • 166 Beiträge

 

Geschrieben 26. November 2010 - 12:46

Prüfe mal, ob die authplay.dll die Version 10,1,102,64 .

-Zahni


Die Datei im neuen Unterverzeichnis hat diese Version.
\msitest\Neuer Ordner\program files\Adobe\Reader 9.0\Reader\

Ich dachte aber, dass es nur eine neue große MSI anstatt Unterverzeichnisse gibt?

Nachtrag
oder meinst Du ich soll die neue MSI auspacken und da rein schauen?

#22 Wurstsalat

Wurstsalat

    Member

  • 204 Beiträge

 

Geschrieben 02. Dezember 2010 - 14:35

ich habe es jetzt mit der 9.4.1 msp genau so gemacht, allerdings anstatt einer neue große MSI Datei wurde nur die alte 9.4.1 MSI um ein paar Bytes Geändert (die Datei ist nur 4 MB Gross), und es wurden 4 neue Unterverzeichnisse erstellt:

Windows\ 5.003.070
CommonAppData\ 479
program files\ 115.312.642
Common\ 6.282.238

wenn ich diese leicht veränderte MSI installiere wird tatsächlich die 9.4.1 verteilt?
Muss ich die neuen 4 Unterverzeichnisse auch auf dem Server kopieren? Bzw auch die msp?

Ich verstehe echt nicht, warum uns adobe immer das Leben schwer macht, die könnten doch 9.4.1 als msi bereitstellen

was war die ursprungsversion welche du patchen wolltest?
deine urpsrüngliche msi hat sich nicht verändert?
du meinst mit den ~4mb größe aber nicht die msp?

#23 Dr.Melzer

Dr.Melzer

    Moderator

  • 26.226 Beiträge

 

Geschrieben 02. Dezember 2010 - 22:56

was war die ursprungsversion welche du patchen wolltest?
deine urpsrüngliche msi hat sich nicht verändert?
du meinst mit den ~4mb größe aber nicht die msp?


Bitte achte in Zukunft darauf auch Großbuchstaben zu nutzen. Wir haben hier genug damit zu tun Probleme zu lösen da brauchen wir nicht auch noch Beiträge die zusätzliche Probleme erzeugen weil sie schlecht zu lesen sind!

Vielen Dank für dein Verständnis!
Never argue with an idíot, they drag you down to their level and beat you with experience!

#24 speedygonzales

speedygonzales

    Member

  • 166 Beiträge

 

Geschrieben 08. Dezember 2010 - 10:17

Mensch Adobe macht mich wahnsinnig!

Ich habe es zu 100% nach eurer Anleitung gemacht, es wird dann das „neue“ Paket verteilt und installiert, die Ereignisanzeige zeigt auch Paket installiert.
Aber ich habe immer noch die 9.4.0 drauf.

Das einzige was ich anders mache ist ein paar Einstellungen in der MST zu ändern, aber daran kann es ja nicht liegen, die MST verwende ich schon lange, da wird bloß den Online Update deaktiviert und ein paar Kleinlichkeiten, alles völlig harmlos.

Mensch was mache ich bloß falsch?

msiexec /a c:\temp\ AcroRead.msi /p c:\temp\adberdrupd941_all_incr.msp

Dann GPO erstellen MST einfügen es wird verteilt installiert, aber wenn ich den Reader starte habe ich immer noch den 9.4.0

da kann man doch nichts falsches machen..

#25 Sunny61

Sunny61

    Expert Member

  • 22.101 Beiträge

 

Geschrieben 08. Dezember 2010 - 12:00

Das einzige was ich anders mache ist ein paar Einstellungen in der MST zu ändern, aber daran kann es ja nicht liegen, die MST verwende ich schon lange, da wird bloß den Online Update deaktiviert und ein paar Kleinlichkeiten, alles völlig harmlos.


Dafür gibt es ADM-Templates in Group Policy Objects. Beispiel No. 24 suchst Du: ADM Templates - Administrative Vorlagen, Weiter unten mal einige Sample´s und Codebeispiele:

msiexec /a c:\temp\ AcroRead.msi /p c:\temp\adberdrupd941_all_incr.msp

Dann GPO erstellen MST einfügen es wird verteilt installiert, aber wenn ich den Reader starte habe ich immer noch den 9.4.0


Und wo ist das neue MSI File? In welcher GPO? Das neue MSI File mußt Du erneut verteilen.
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#26 speedygonzales

speedygonzales

    Member

  • 166 Beiträge

 

Geschrieben 08. Dezember 2010 - 16:42

Dafür gibt es ADM-Templates in Group Policy Objects.


Danke für den Link werde ich mich da einlesen.

Und wo ist das neue MSI File? In welcher GPO? Das neue MSI File mußt Du erneut verteilen


Ich habe eine neue GPO gemacht welche gleich das Paket als 9.4.1 erkennt, die neue MSI Verteilt, die Ereignisanzeige bestätigt die einwandfreie installation, wenn ich aber Adobe starte erscheint unter Info immer noch 9.4.0.

Von Norbert habe ich ein alten Posting gefunden, müsste ich evtl sowas machen? die Einstellung habe ich aber noch nie verwendet..

http://www.mcseboard....ml#post1001931 (Adobe Update per GPO)

"- Bestehende Softwareverteilungsrichtlinie öffnen
- Neues Paket (Adobe 9.3.1) hinzufügen und "dieses Paket aktualisiert folgendes Paket (Adobe 9.3) auswählen (passiert teilweise automatisch)."

#27 Sunny61

Sunny61

    Expert Member

  • 22.101 Beiträge

 

Geschrieben 08. Dezember 2010 - 18:46

Ich habe eine neue GPO gemacht welche gleich das Paket als 9.4.1 erkennt, die neue MSI Verteilt, die Ereignisanzeige bestätigt die einwandfreie installation, wenn ich aber Adobe starte erscheint unter Info immer noch 9.4.0.


Hmm, sehr komisch. Ich hab schon zig mal so gemacht. Hast Du die MST auch mit in der GPO eingebunden?

https://www.mcseboar....ml#post1001931 (Adobe Update per GPO)

"- Bestehende Softwareverteilungsrichtlinie öffnen
- Neues Paket (Adobe 9.3.1) hinzufügen und "dieses Paket aktualisiert folgendes Paket (Adobe 9.3) auswählen (passiert teilweise automatisch)."


Ausprobieren, wenn Norbert das schreibt funktioniert das im Normalfall auch.

BTW: Die URL ist nicht vollständig, und Norbert hat viele Postings bisher geschrieben. ;)
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#28 speedygonzales

speedygonzales

    Member

  • 166 Beiträge

 

Geschrieben 09. Dezember 2010 - 08:51

Hmm, sehr komisch. Ich hab schon zig mal so gemacht. Hast Du die MST auch mit in der GPO eingebunden?


jupp!

Ereignistyp: Informationen
Ereignisquelle: MsiInstaller
Ereigniskategorie: Keine
Ereigniskennung: 11707
Datum: 08.12.2010
Zeit: 11:06:13
Benutzer: ******admin
Computer: ****
Beschreibung:
Produkt: Adobe Reader 9.4.1 - Deutsch -- Installationsvorgang erfolgreich abgeschlossen.


Ausprobieren, wenn Norbert das schreibt funktioniert das im Normalfall auch.


werde ich machen, es ist ein versuch Wert.

BTW: Die URL ist nicht vollständig, und Norbert hat viele Postings bisher geschrieben. ;)


hier die richtige URL..
wobei, die "C64 Fehlermeldung" war es den Tipfehler Wert :D

http://www.mcseboard...tml#post1001931

#29 Sunny61

Sunny61

    Expert Member

  • 22.101 Beiträge

 

Geschrieben 09. Dezember 2010 - 10:29

jupp!


Dann lass die MST doch mal weg.
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#30 Marco31

Marco31

    Junior Member

  • 375 Beiträge

 

Geschrieben 21. Dezember 2010 - 14:34

Hallo Leute,

ich habe heute auch (anscheinend vergeblich) versucht die aktualisierte MSI vom Reader 9.4.1 zu erstellen...
Habe eigentlich auch alles wie beschrieben durchgeführt; erst die 9.4 MSI runtergeladen, dann die 9.4.1 MSP runtergeladen und mit dem Befehl

msiexec /a C:\Adobe\AdbeRdr940_de_DE.msi /p C:\Adobe\AdbeRdrUpd941_all_incr.msp

die MSI versucht upzudaten. Alles ohne Probleme durchgelaufen.
Ab hier wirds dann etwas merkwürdig: die MSI hat sich nicht verändert. Zum Test habe ich die MSI auf nem Rechner manuelle installiert, und oh Freude, Windows7 zeigt an dass (angeblich) Adobe Reader 9.4.1 installiert ist.
Also in die GPO gepackt und auch diese hat das Paket als 9.4.1 erkannt.

Da ich aber ein mißtrauischer Mensch bin habe ich mir mal bei den beiden installierten PC'S die authplay.dll angesehen, die ja jetzt Version 10,1,102,64 sein sollte....
ABER: Essig wars! Die Datei ist immer noch Version 10,1,85,1 vom 16.09.2010!

Kann sich das wer erklären...?