Zum Inhalt wechseln


Foto

Probleme: Failover Cluster mit Hyper-V


  • Bitte melde dich an um zu Antworten
15 Antworten in diesem Thema

#1 Stub1004

Stub1004

    Newbie

  • 63 Beiträge

Geschrieben 25. März 2009 - 08:10

Hallo zusammen

Ich habe zwei gleiche W2k8 Enterprise Server x64 aufgesetzt und bei beiden das W2k8 Feature "Failover Clusterverwaltung" und die Rolle "Hyper-V" installiert. Danach einen Cluster erstellt und über iSCSI das NAS angebunden. Soweit funktioniert alles tiptop.

Nun möchte ich einen Virtuellen Computer hoch verfügbar machen. Dazu gehe ich in die Clusterverwaltung und wähle dort unter "Dienste und Anwendungen konfigurieren" den Eintrag "Virtueller Computer" aus (Vorher habe ich mit dem Hyper-V Manager einen virtuellen Computer erstellt und die Daten auf mein Nas verlinkt. In meinem Fall N:\Hyper-V). Bei der Erstellung der Anwendung in der Clusterverwaltung erhalte ich den Fehlerbericht:

Fehler beim Konfigurieren der Rolle "Virtueller Computer" für "test1".

(Test 1 ist mein virtueller Computer, welchen ich vorhin erstellt hatte)

Kennt jemand dieses Problem? Gibt es dazu eine Lösung oder einen Workarround? Ich wäre sehr dankbar für Hilfen...

Liebe Grüsse
Stub1004

#2 TheDonMiguel

TheDonMiguel

    Expert Member

  • 1.518 Beiträge

Geschrieben 25. März 2009 - 10:24

Hi

Der Cluster Validator lief ohne Fehler durch, das heisst dein Storage wird auch supportet und wird nicht als Fehler aufgeführt? Denn nicht jedes "günstige" Storage unterstüttz "SCSI-3 Persistent Reservation"...

Ansonsten, steht mehr zum Issue im Event-Log?

Cheers
Miguel
Let's talk about Virtualization and Private Cloud: www.server-talk.eu

Jedes grosses Unterfangen hat einen Anfang, doch wahrer Ruhm gebühret jenen, die den Mut haben eine Sache gänzlich zu Ende zu führen.
Sir Francis Drake, 1578

#3 Stub1004

Stub1004

    Newbie

  • 63 Beiträge

Geschrieben 25. März 2009 - 11:59

Ja der Cluster Validator lief ohne Fehler durch. Das NAS ist von Netapp und daher nicht ein "billiges" ;-)

Leider steht im Eventlog auch nichts drinn.

#4 Lian

Lian

    Moderator

  • 17.755 Beiträge

Geschrieben 25. März 2009 - 12:20

Welches Quorum Model wird verwendet?

Sicher, daß Du im Cluster Management SnapIn keine Events der Quelle Clustering hast?

Was sagt das cluster.log?
Clustering and High Availability : How to create the cluster.log in Windows Server 2008 Failover Clustering

Folgender TechNet Artikel beschreibt die Voraussetzungen und Installation im Detail:
Hyper-V Step-by-Step Guide: Hyper-V and Failover Clustering
Prüfen den mal bitte gegen Deinen Ist-Zustand.
You can have it good, fast, or cheap. Pick two.
–––
Microsoft MVP [Data & Storage - Cluster]

#5 Stub1004

Stub1004

    Newbie

  • 63 Beiträge

Geschrieben 25. März 2009 - 12:25

Hier ist das Cluster.log:

00000988.00000b24::2009/03/25-12:12:25.533 INFO [RES] Physical Disk: Supplied path N:\HyperV\test1\test1 is a FS path, vol-mp \\.\N:\
00000988.00000b24::2009/03/25-12:12:25.534 INFO [RES] Physical Disk: Supplied device path N:\ is a FS path, vol-mp \\?\Volume{2b99bbea-1600-11de-a3b4-00215a4728b0}\
00000988.00000b24::2009/03/25-12:12:25.564 INFO [RES] Physical Disk: Supplied path N:\HyperV\test1\test1 is a FS path, vol-mp \\.\N:\
00000988.00000b24::2009/03/25-12:12:25.564 INFO [RES] Physical Disk: Supplied device path N:\ is a FS path, vol-mp \\?\Volume{2b99bbea-1600-11de-a3b4-00215a4728b0}\
00000988.00000b24::2009/03/25-12:12:25.892 INFO [RES] Physical Disk: Supplied path N:\HyperV\test1\test1\test1.vhd is a FS path, vol-mp \\.\N:\
00000988.00000b24::2009/03/25-12:12:25.892 INFO [RES] Physical Disk: Supplied device path N:\ is a FS path, vol-mp \\?\Volume{2b99bbea-1600-11de-a3b4-00215a4728b0}\
00000988.00000b24::2009/03/25-12:12:25.922 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
00000988.00000b24::2009/03/25-12:12:25.926 INFO [RES] Physical Disk: Exit EnumerateDevices: status 0
00000988.00000b24::2009/03/25-12:12:25.927 INFO [RES] Physical Disk: Exit GetVolumeDisks: status 0
00000988.00000b24::2009/03/25-12:12:25.927 INFO [RES] Physical Disk: Exit GetSystemDiskNumbers: status 0
00000988.00000b24::2009/03/25-12:12:25.927 INFO [RES] Physical Disk: Exit GetVolumeDisks: status 0
00000988.00000b24::2009/03/25-12:12:25.927 INFO [RES] Physical Disk: Exit GetNtldrDiskNumbers: status 0
00000988.00000b24::2009/03/25-12:12:25.927 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
00000988.00000b24::2009/03/25-12:12:25.928 INFO [RES] Physical Disk: Disk index 0 has OS file on it
00000988.00000b24::2009/03/25-12:12:25.928 INFO [RES] Physical Disk: Exit EnumerateDevices: status 0
00000988.00000b24::2009/03/25-12:12:25.928 INFO [RES] Physical Disk: Enter EnumerateDevices: EnumDevice 0
00000988.00000b24::2009/03/25-12:12:25.929 INFO [RES] Physical Disk: Disk index 0 has OS file on it
00000988.00000b24::2009/03/25-12:12:25.929 INFO [RES] Physical Disk: Exit EnumerateDevices: status 0
00000988.00000b24::2009/03/25-12:12:25.929 INFO [RES] Physical Disk: Exit HardDiskpGetDisksWithOSFiles: status 0
00000988.00000b24::2009/03/25-12:12:25.931 INFO [RES] Physical Disk: Port driver supports clustering
00000988.00000b24::2009/03/25-12:12:25.931 INFO [RES] Physical Disk: Exit IsClusterSupported: ClusterSupported 1, status 0
00000988.00000b24::2009/03/25-12:12:25.931 INFO [RES] Physical Disk: Exit GetAdadpterBusType: PortNumber 1, BusType 9, status 0


Ich kann hier nichts tragisches herauslesen. ihr schon? Den Microsoft-Artikel (Step-by-Step Guide) kenn ich schon und diesen habe ich auch so durchgespielt.

Wie gesagt, das Clusterin ansich funktioniert schon, aber ich kann keine virtuellen Machinen hochverfügbar machen.

#6 NilsK

NilsK

    Expert Member

  • 8.717 Beiträge

Geschrieben 25. März 2009 - 12:50

Moin,

hast du deine iSCSI-Volumes denn über das Snapdrive als Cluster-Drives angelegt?

Gruß, Nils

Nils Kaczenski

MVP Hyper-V
... der beste Schritt zur Problemlösung: Anforderungen definieren!

Kostenlosen Support gibt es nur im Forum, nicht privat!


#7 Stub1004

Stub1004

    Newbie

  • 63 Beiträge

Geschrieben 25. März 2009 - 12:51

Hi Nils

Ja ich habe ein iSCSI-Volume über den iSCSI Initator als Cluster-Drive angelegt. Das Snapdrive habe ich nicht.

Ich bin nun etwas weiter. Das Problem konnte ich lösen, indem ich statt einen Laufwerksbuchstaben für mein Shared Storage die GUID nahm.

#8 Stub1004

Stub1004

    Newbie

  • 63 Beiträge

Geschrieben 25. März 2009 - 16:21

Nur hat dies ein anderes Problem generiert. Nämlich werden nun beim Importieren der virtuellen Computer in die Failover-Clusterverwaltung die Konfigurationen im Hyper-V Manager komplett gelöscht. Das heisst, ich seh dort keinen virtuellen Server mehr. Und daher lässt sich dieser dann in der Failover-Clusterverwaltung auch nicht starten...

Hab ich so noch nie gesehen.... sagt das jemand was?

Zumindest gibts eine Event-ID :

ID: 1069 Quelle: FailoverClustering
Bei der Clusterressource "Konfiguration des virtuellen Computers "xxx"" im geclusterten Dienst oder in der geclusterten Anwendung "Virtual Machine" ein Fehler aufgetreten.

Zudem:

Protokollname: Microsoft-Windows-Hyper-V-High-Availability-Admin
Quelle: Microsoft-Windows-Hyper-V-High-Availability
Datum: 25.03.2009 17:02:09
Ereignis-ID: 21203
Aufgabenkategorie:Keine
Ebene: Fehler
Schlüsselwörter:
Benutzer: SYSTEM
Computer: xxx
Beschreibung:
Fehler beim Erstellen des virtuellen Netzwerk-Switchports "'798beb4d-2925-433a-bd71-bf7d552dd1c7'. (HRESULT 0x8004100c)".


Protokollname: Microsoft-Windows-Hyper-V-High-Availability-Admin
Quelle: Microsoft-Windows-Hyper-V-High-Availability
Datum: 25.03.2009 17:02:09
Ereignis-ID: 21117
Aufgabenkategorie:Keine
Ebene: Fehler
Schlüsselwörter:
Benutzer: SYSTEM
Computer: xxx
Beschreibung:
"Konfiguration des virtuellen Computers "xxx"": Fehler beim Erstellen der virtuellen Netzwerk-Switchports für den virtuellen Computer. Prüfen Sie die Einstellungen des virtuellen Computers.


Protokollname: Microsoft-Windows-Hyper-V-High-Availability-Admin
Quelle: Microsoft-Windows-Hyper-V-High-Availability
Datum: 25.03.2009 17:02:09
Ereignis-ID: 21104
Aufgabenkategorie:Keine
Ebene: Fehler
Schlüsselwörter:
Benutzer: SYSTEM
Computer: xxx
Beschreibung:
"Konfiguration des virtuellen Computers "xxx"": Fehler beim Aufheben der Registrierung des virtuellen Computers beim Verwaltungsdienst für virtuelle Computer.

#9 Lian

Lian

    Moderator

  • 17.755 Beiträge

Geschrieben 26. März 2009 - 09:57

Kannst Du bitte ein wenig mehr über Dein Setup schreiben?
Mich würden die Nodes interessieren und die Netapp, was ganz genau wird eingesetzt?
Beantworte bitte auch meine Frage von weiter oben: Welches Quorum Model setzt Du ein?
Wird Multipathing verwendet, wird ein eigenes VLAN für den iSCSI Verkehr verwendet?
You can have it good, fast, or cheap. Pick two.
–––
Microsoft MVP [Data & Storage - Cluster]

#10 Stub1004

Stub1004

    Newbie

  • 63 Beiträge

Geschrieben 26. März 2009 - 12:46

Ich habs rausgefunden....

Mein geliebter TrendMicro Virenscanner machte Probleme. Ich hab ihn für die Hyper-V Verzeichnisse und Cluster Shared Storage abgeschaltet...nun klappts....

#11 Lian

Lian

    Moderator

  • 17.755 Beiträge

Geschrieben 26. März 2009 - 12:51

Ok, das erklärt einiges.

Dazu gibt es einen KB Artikel:
Antivirus software that is not cluster-aware may cause problems with Cluster Services

Prinzipiell geht es um das Thema Kernel Filter Treiber, in dem Fall File System Filter Treiber. Da muss man bei einem Cluster generell genauer hinsehen:
Cluadmin.de: Filtertreiber im Cluster

Danke für die Rückmeldung, gute Arbeit ;)
You can have it good, fast, or cheap. Pick two.
–––
Microsoft MVP [Data & Storage - Cluster]

#12 mcpharma

mcpharma

    Member

  • 209 Beiträge

Geschrieben 26. März 2009 - 12:55

Ich habs rausgefunden....

Mein geliebter TrendMicro Virenscanner machte Probleme. Ich hab ihn für die Hyper-V Verzeichnisse und Cluster Shared Storage abgeschaltet...nun klappts....



Übrigens unterstützt TrendMicro kein Hyper-V und zerrt bei solchen virtuellen Maschinen schwer an der Perfomance :(
ITA / MCP / MCTS

passed: 70-620
next: 70-290

#13 Stub1004

Stub1004

    Newbie

  • 63 Beiträge

Geschrieben 26. März 2009 - 13:10

Interessanter Ansatz.
Welchen Virenschutz empfiehlst du den für Hyper-V Host und Guest?

#14 mcpharma

mcpharma

    Member

  • 209 Beiträge

Geschrieben 26. März 2009 - 13:45

Interessanter Ansatz.
Welchen Virenschutz empfiehlst du den für Hyper-V Host und Guest?


Da uns genau das Problem auch genervt hat, haben wir uns ein wenig umgesehen...

Jetzt haben wir mal NOD32 Antivirus Business installiert und dass läuft wirklich gut und flüssig bei Hyper-V

richtig stressig ist TM wenn du es auf einem Guest-Terminalserver installierst, denn dann startet er sich bei jedem connect einen neuen Task...

ich hoffe ich konnte helfen
ITA / MCP / MCTS

passed: 70-620
next: 70-290

#15 Lian

Lian

    Moderator

  • 17.755 Beiträge

Geschrieben 26. März 2009 - 14:07

Jetzt haben wir mal NOD32 Antivirus Business installiert und dass läuft wirklich gut und flüssig bei Hyper-V

Zudem: Generell würde ich immer gerne eine Aussage seitens des Herstellers haben, daß die Version cluster-aware ist.
You can have it good, fast, or cheap. Pick two.
–––
Microsoft MVP [Data & Storage - Cluster]