Zum Inhalt wechseln


Foto

Exchange 2007 Abwesenheitsassistent Problem - Autodiscover?


  • Bitte melde dich an um zu Antworten
12 Antworten in diesem Thema

#1 simonak

simonak

    Senior Member

  • 351 Beiträge

 

Geschrieben 12. August 2008 - 14:40

Hallo!

Haben beim Kunden einen Exchangeserver 2007 stehen. Da die Firma eine Woche in Betriebsferien gehen will, soll jeder Benutzer der eine E-Mail geschickt bekommt automatisch eine Abwesenheitsnachricht zurück schicken.

Meine erste Frage, global für die ganze Firma kann man dies nicht einstellen, richtig? Wäre aber nicht so wild.

Wollten nun den Abwesenheitsassistenten bei Outlook 2007 eintragen, doch dieser bringt folgende Fehlermeldung:

Ihre Abwesenheitseinstellungen können nicht angezeigt werden, da der Server zurzeit nicht verfügbar ist.


Danach habe ich natürlich gleich gegoogelt und habe herausgefunden, dass Autodiscover evtl. funktionieren muss. Habe ich am Client auch getestet, hier kommt es zu folgender Fehlermeldung:

Attempting URL https://meinserver.m...utodiscover.xml fount through SCP
Autodiscover to https://meinserver.m...utodiscover.xml starting
Autodiscover to https://meinserver.m...utodiscover.xml FAILED (0x800C8203)


Danach versucht er sich noch mehrfach auf https://meinedomain.de/Autodiscover/Autodiscover.xml etc. zu verbinden. Die .de Domain haben wir hier aber gar nicht im Einsatz, kann also nicht funktionieren.

Habe in der Exchangeshell schon

Set-ClientAccessServer -Identity -AutodiscoverServiceInternalURI "https://meinserver.meinedomain.lokal/autodiscover/autodiscover.xml"


und

set-WebServicesVirtualDirectory -Identity "EWS (Standardwebsite)" -InternalUrl https://meinserver.m...S/Exchange.asmx


ausgeführt. Bis jetzt allerdings noch alles ohne Erfolg. Was kann ich noch tun um den Abwesenheitsassistenten zum Laufen zu bekommen?

Gruß

Daniel

#2 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 12. August 2008 - 14:59

Was bekommst du denn zurück wenn du mit dem IE auf die Autodiscover URL browst?
Was gibt den das Test-OutlookWebServices CMDlet zurück wenn du es in der EMS ausführst?
MCT

#3 simonak

simonak

    Senior Member

  • 351 Beiträge

 

Geschrieben 12. August 2008 - 15:03

Erst ein Zertifikatsfehler,da es ein selbst erstelltes Zertifikat ist, aber durch das Klicken auf "Fortsetzen" komme ich auf die .XML Datei drauf. Habe das Zertifikat aber sicherheitshalber schon einmal auf dem Rechner installiert. Da meckert er jetzt schon gar nicht mehr und kommt direkt auf die Seite.

#4 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 12. August 2008 - 15:06

Da liegt auch das Problem, solange du Zertifikatsfehlermeldungen bekommst, werden die ganzen Exchange WebServices nicht richtig funktionieren.
Ist das Zertifikat auf den richtigen Namen ausgestellt?
MCT

#5 simonak

simonak

    Senior Member

  • 351 Beiträge

 

Geschrieben 12. August 2008 - 18:03

Ich hab aber das Zertifikat lokal auf dem Rechner installiert. Jetzt komm ich ja ohne Fehlermeldung drauf. Wenn ich das bei jedem Rechner mache, ist das doch normal ausreichend.

#6 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 12. August 2008 - 18:39

was wirft denn
Test-OutlookWebServices | fl
direkt am Exchange Server aus?
MCT

#7 simonak

simonak

    Senior Member

  • 351 Beiträge

 

Geschrieben 12. August 2008 - 19:12

Hier spuckt er folgendes aus:

Id : 1003
Type : Information
Message : Die AutoErmittlung wird gleich mit E-Mail-Adresse Administrator@meinedomain.de getestet.

Id : 1007
Type : Information
Message : Der Server meinserver.meinedomain.lokal mit dem veröffentlichten Namen https://meinserver.m...S/Exchange.asmx & https://meinserver.m...S/Exchange.asmx wird getestet.

Id : 1019
Type : Information
Message : Es wurde ein gültiger Verbindungspunkt für den AutoErmittlungsdienst gefunden. Die URL dieses Objekts für die AutoErmittlung ist https://meinserver.m...utodiscover.xml.

Id : 1013
Type : Error
Message : Fehler Der Remoteserver hat einen Fehler zurückgegeben: (405) Unzulässige Methode. beim Herstellen der Verbindung mit https://meinserver.m...utodiscover.xml.

Id : 1006
Type : Error
Message : Es konnte keine Verbindung mit dem AutoErmittlungsdienst hergestellt werden.



#8 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 12. August 2008 - 20:26

Entferne das virtuelle Autodiscover
Remove-AutodiscoverVirtualDirectory -Identity "MeinServer\Autodiscover (Default Web Site)"

und lege es wieder an
New-AutodiscoverVirtualDirectory -Identity "MeinServer\Autodiscover (Default Web Site)"

Prüfe dann im IIS Manager ob ASP.NET 2.0 erlaubt ist, dann ob das Autodiscover Verzeichnis vohanden ist und starte IIS mit
iisreset /force
neu.

Prüfe ob die Windows Authentifizierung auf dem Virtuellen Verzeichnis aktiv ist
MCT

#9 TheDonMiguel

TheDonMiguel

    Expert Member

  • 1.522 Beiträge

 

Geschrieben 13. August 2008 - 07:01

Hi

Schau dir mal diesen Eintrag an: Out of Office Error Message in Outlook 2007 | Server Talk

Gruss
Miguel
Let's talk about Virtualization and Private Cloud: www.server-talk.eu

Jedes grosses Unterfangen hat einen Anfang, doch wahrer Ruhm gebühret jenen, die den Mut haben eine Sache gänzlich zu Ende zu führen.
Sir Francis Drake, 1578

#10 simonak

simonak

    Senior Member

  • 351 Beiträge

 

Geschrieben 13. August 2008 - 09:50

@BrainStorm, habe das Autodiscoververzeichnis entfernen können. Kann es allerding nicht wieder erstellen.

Mit diesem Befehl konnte ich das Verzeichnis löschen. Ist auch definitv weg:

Remove-AutodiscoverVirtualDirectory -Identity "meinserver\Autodiscover (Standardwebsite)"


Wenn ich es alledings neu erstellen will passiert folgnedes:

E:\Dokumente und Einstellungen\Administrator\Desktop>New-AutodiscoverVirtulDirectory -Identity "meinserver\Autodiscover (Standardwebsite)"

New-AutodiscoverVirtualDirectory : A parameter cannot be found that matches parameter name 'Identity'.
At line:1 char:43
+ New-AutodiscoverVirtualDirectory -Identity <<<< "meinserver\Autodiscover (Standardwebsite)"


Wie bekomme ich das Verzeichnis wieder eingetragen?

@TheDonMiguel, die Berechtigungen der Verzeichnise habe ich auch einmal überprüft. Bei EWS war hier "Anonymous" aktiviert. Habe ich ausgeschaltet und IIS neu gestartet. Dennoch fehler mir nun das Autodiscoververzeichnis im IIS.

Konnte das Verzeichnis über folgenden Befehl doch wieder herstellen:

New-AutodiscoverVirtulDirectory


Danach war das Verzeichnis wieder im IIS da. Habe noch die Berechtigungen angepasst wie im Link von TheDonMiguel, iisreset /noforce und Autodiscover läuft, genauso wie der Abwesenheitsassistent. Danke für eure Hilfe!

#11 BrainStorm

BrainStorm

    Expert Member

  • 2.418 Beiträge

 

Geschrieben 13. August 2008 - 12:11

Super, danke für die Rückmeldung
MCT

#12 dermario2

dermario2

    Board Veteran

  • 1.421 Beiträge

 

Geschrieben 11. Januar 2010 - 09:06

Hi,

leider funktioniert es bei einem (!) Benutzer, der nicht in der Domäne steckt, noch immer nicht. Frage: Muss im IIS beim virtuellen Verzeichnis "EWS" auch die Basic Authentication aktiviert sein? Hier ist nur "Integrated Windows Authentication" aktiviert.

Danke u. lG,
Mario.

#13 computerklinik

computerklinik

    Newbie

  • 1 Beiträge

 

Geschrieben 18. Februar 2013 - 10:38

Hallo Leute,

 

das richtige neuerstellen des Virtuellen Autodiscover Verzeichnis geht mit diesem Befehl.

 

New-AutodiscoverVirtualDirectory -WebSiteName "Default Web Site" -BasicAuthentication $true -WindowsAuthentication $true

 

Grüße


Bearbeitet von computerklinik, 18. Februar 2013 - 10:39.