Zum Inhalt wechseln


Foto

Speicherort der wpad.dat


  • Bitte melde dich an um zu Antworten
4 Antworten in diesem Thema

#1 Nobby

Nobby

    Newbie

  • 59 Beiträge

 

Geschrieben 26. Juni 2008 - 11:05

Hallo zusammen,
ich habe zwar hier im Board über die Suchen-Funktion versucht, mein Problem zu lösen, aber bin leider gescheitert. Deshalb meine Frage und ich hoffe, Ihr könnt mir helfen.

Ich betreue eine Domäne, in der ich über GPO einen bestimmten Proxy-Server vorgegeben habe.

Dieser Proxy-Server liegt jedoch nicht in meinem Zuständigkeitsbereich und ich kann somit auch nicht auf den Webserver zugreifen.

Das funktioniert auch alles ganz prima. Nunmehr ist es aber notwendig, dass ich bestimmten Usern das Recht einräumen muss, nur ganz bestimmte Internetseiten aufzurufen. Das bewerkstellige ich mit folgenden Script.

- - - - -
function FindProxyForURL(url, host)
{
if (dnsDomainIs(host, ".maus.de") ||
dnsDomainIs(host, ".katze.de") ||
dnsDomainIs(host, ".hund.de") ||
dnsDomainIs(host, ".wasweißich.de"))
return "PROXY mein.proxy.de:3128";
else
return "DIREKT";
}
- - - - -
Die Alternative "DIREKT" habe ich gewählt, damit die Intranet-Seiten, die den Proxy-Server umgehen müssen auch angezeigt werden können

Ich habe in den Gruppenrichtlinen bei Benutzerkonfiguration die Verbindungseinstellungen in der Weise geändert, dass aktuelle Verbindungeinstellungen importiert werden sollen. Als Speicherort habe ich angegeben "file://c:/wpad.dat. Dies funktioniert aber nur dann, wenn auf dem entsprechenden Client diese Datei hinterlegt ist. Ich möchte aber, dass die Datei zentral auf dem Server abgelegt ist und darauf zugegriffen wird. Der Versuch, anstelle

"file://c:/wpda.dat"

den Speicherort

"file://%logonserver%/netlogon/wpda.dat"

zu wählen, habt ebenfalls nicht funktioniert.

Kann mir hier jemand helfen?

#2 Shandurai

Shandurai

    Senior Member

  • 384 Beiträge

 

Geschrieben 28. Juni 2008 - 11:57

moin

klar, kein problem dir zu helfen...
lege die wpad.dat in das root eines webservers. die wpad.dat datei kannst du dann per dns-alias WPAD oder per dhcp option 252 bekannt geben. den browser auf automatische suche stellen und dann sollte das funktionieren...

auf dem webserver stehen je nach typ noch konfigurationen an.
mangels zeit kann ich dir die links grad nicht raussuchen, mach ich aber nachher.

eine gute quelle sollte ISA Server FAQ sein, da steht das irgendwo... ansonsten bis nachher

gruß, andre

hier :)
MSXFAQ.DE - WPad
Gruppenrichtlinien - Übersicht, FAQ und Tutorials

#3 Nobby

Nobby

    Newbie

  • 59 Beiträge

 

Geschrieben 04. Juli 2008 - 09:42

Hallo Andre,
vielen Dank für Deine Hilfe, aber ich habe leider keinen Webserver, das ist eben mein Problem. Ich kann zwar die Datei auf das Root-Verzeichnis des Servers legen, aber darauf greifen eben meine User während eines Internetaufrufes nicht zu.

Gruß Nobby

#4 Shandurai

Shandurai

    Senior Member

  • 384 Beiträge

 

Geschrieben 04. Juli 2008 - 18:29

moin

was spricht gegen die installation des IIS? dann hast du einen webserver ;-)

#5 CyberTim

CyberTim

    Newbie

  • 6 Beiträge

 

Geschrieben 20. Juni 2017 - 07:33

Ich will zwar nicht Leichenfledderer spielen und den alten Beitrag herauskramen, aber dieser Beitrag war bei der Suche mit google immer eines der ersten Ergebnisse, bei der Suche nach einer Lösung bei meinem Problem. Vielleicht geht es anderen auch so und freuen sich, wenn sie die Lösung finden...

 

Nachdem sich der Pfad/Speicherort der wpad.dat bei uns geändert hatte, haben einige Clients diese einfach nicht aktualisiert. Allen gemein: es waren etwas ältere Clients. Die nagelneuen hatten hingegen keine Probleme.

Um es kurz zu machen: Des Rätsels Lösung war ein ipconfig -release gefolgt von einem ipconfig -renew

Die Clients hatten die DHCP Option scheinbar zwischengespeichert und trotz Neustart bzw. Trennen vom Netz und erneutem Verbinden nicht aktualisiert. Wieso diese Clients das gemacht haben und andere nicht, kann ich nicht nachvollziehen. Jetzt tut es jedenfalls :)