Zum Inhalt wechseln


Foto

Langsamer Zugriff auf Datei im Neztwerk unter Windows XP


  • Bitte melde dich an um zu Antworten
77 Antworten in diesem Thema

#1 pingoin

pingoin

    Newbie

  • 5 Beiträge

 

Geschrieben 04. September 2003 - 09:57

Wir haben ein Problem mit unserem Netzwerk.

- Win 2k Server
- 5 Win XP-Prof Rechner
- 2 Win 98 Rechner

Lauft alles.

Problem ist folgendes.

Bei den Windows XP Rechner sind unter Arbeitsplatz diverse Netzlaufwerke installiert. Bei booten findet jeder Rechner auch diese Netzlaufwerke. Nach einiger Zeit, wenn diese Netzlaufwerke nicht benutzt wurden, sind diese als "nicht Verfügbar" gekennzeichnet. Klickt man drauf, kommt man jedoch rein. Das dauert allerdings sehr lange, bis zu einer Minute.

Das Problem ist wohl bekannt. Im Buch"SchnellAnleitung, Netzwerke mit Windows XP" von DATA BECKER ist diese Problem auf der Seite 34 beschrieben. Dort ist auch ein Link zur Problembehebung. http://support.micro...b;EN-US;q309376
Doch genau dieser Link funktioniert nicht.

Hat wer ne Lösung?

Gruß pingoin

#2 Necron

Necron

    Moderator

  • 11.556 Beiträge

 

Geschrieben 04. September 2003 - 10:01

Guck mal hier: http://www.mcseboard...ight=Windows XP

Cheers,
Daniel

-Daniel's Tech Blog-


#3 Lusthase

Lusthase

    Newbie

  • 7 Beiträge

 

Geschrieben 04. September 2003 - 10:12

1. Man nehme Google

2. Man suche nach "A Long Time Is Needed to Open a File By Using SMB"

3. Man findet: http://www.sbslinks.com/windows_xp.htm


Offensichtlich ist der Patch im XP Service Pack 1 integriert worden, wie ein Liste in die Bugfix-Liste des SP1 offenbart.

http://www.windowsre...2k/sp1fixes.htm

Ich denke, daher hat Microsoft den Hotfix runtergenommen von seiner WEBSeite.

#4 pingoin

pingoin

    Newbie

  • 5 Beiträge

 

Geschrieben 04. September 2003 - 12:48

Schon mal vielen Dank für die Anregungen, auch wenn ich bis dato noch keine zufriedenstellendes Ergebnis habe.

@ Lusthase

Der letzte Link führt leider ebenfalls ins leere. Es mag sein das ** den Link entnommen hat, da der Patch in SP1 integriert wurde. Dann frage ich mich warum es nicht funktioniert. Schließlich ist auf allen Win xp Rechnern SP1 installiert worden.


@ Necron
Ich habe mal deinen Link weiter verfolgt und bin auf einen Hinweis gekommen, nach dem ich in der Regedit einen Änderung vornehmen mußte.

Ein kleines Problem ist damit behoben. "Netzwerk nicht verfügbar" wird nicht mehr angezeigt. Aber die Geschwindigkeit des Zugreiffs ist immer noch sehr langsam.

Noch ne Idee

#5 CJMeyer

CJMeyer

    Newbie

  • 5 Beiträge

 

Geschrieben 04. September 2003 - 13:11

Hallo Pingoin,

bezüglich des Problems mit dem langsamen Dateizugriff, würde meine Vermutung in die Richtung gehen, dass bei den Netzwerklaufwerken nicht die Option "offline verfügbar machen" (oder so ähnlich) ausgewählt wurde.
Ich meine mich erinnern zu können, dass diese Option den Zugriff beschleunigen müsste.

100%ig sicher bin ich mir allerdings nicht.


Ich hoffe trotzdem geholfen zu haben.

Gruss

CJMeyer

#6 pingoin

pingoin

    Newbie

  • 5 Beiträge

 

Geschrieben 04. September 2003 - 13:23

@CJMeyer

wo kann ich das den einstellen?

Gruß pingoin

#7 CJMeyer

CJMeyer

    Newbie

  • 5 Beiträge

 

Geschrieben 04. September 2003 - 13:32

Ich habe mal die Hilfefunktion von Windows 2000 befragt und als Antwort, unter Anderem das nachfolgend aufgeführte bekommen:

So stellen Sie eine Datei oder einen Ordner offline zur Verfügung
Klicken Sie im Arbeitsplatz oder in der Netzwerkumgebung auf die freigegebene Netzwerkdatei oder den Ordner, den Sie offline zur Verfügung stellen möchten.
Klicken Sie im Menü Datei auf Offline verfügbar machen.
Wichtig
Die Option Offline verfügbar machen wird nur dann im Menü Datei aufgeführt, wenn Sie den Computer auf das Verwenden von Offlinedateien eingerichtet haben. Weitere Informationen zum Einrichten des Computers für das Verwenden von Offlinedateien finden Sie unter 123
Anmerkungen
Wenn Sie zum ersten Mal ein Objekt offline zur Verfügung stellen, führt Sie der Assistent für Offlinedateien durch das Verfahren. Sobald das Dialogfeld Synchronisieren angezeigt wird, steht das Objekt offline zur Verfügung.
Sie können sowohl einzelne Dateien aus einem freigegebenen Netzwerkordner als auch einen vollständigen freigegebenen Netzwerkordner offline verfügbar machen. Bei vollständigen Ordnern werden alle Dateien im betreffenden freigegebenen Ordner beim nächsten Synchronisieren der Computer automatisch offline zur Verfügung gestellt.
Wenn Sie eine Verknüpfung zu einer Datei offline zur Verfügung stellen, wird die betreffende Datei verfügbar gemacht. Dies gilt nicht für Ordner; wenn Sie hier die Verknüpfung offline bereitstellen, erstreckt sich der Vorgang nicht auf den Inhalt des Ordners.
Bei einer Änderung im Status der Netzwerkverbindung wird ein Symbol für Offlinedateien im Statusbereich angezeigt, und Sie werden mit einer Meldung im Statusbereich über diese Statusänderung informiert. Wenn die Meldung besagt, dass Sie offline arbeiten, können Sie die Arbeit an den Dateien wie gewohnt fortsetzen oder auch im Statusbereich auf das Symbol für Offlinedateien klicken, so dass weitere Informationen zum Status der Verbindung angezeigt werden.
Um das Bereitstellen einer Datei oder eines Ordners für den Offlinebetrieb rückgängig zu machen, klicken Sie mit der rechten Maustaste auf das betreffende Objekt, und deaktivieren Sie Offline verfügbar machen erneut.

123:
So richten Sie den Computer für das Verwenden von Offlinedateien ein
1.Öffnen Sie den Arbeitsplatz.
2.Klicken Sie im Menü Extras auf Ordneroptionen.
3.Stellen Sie sicher, dass das Kontrollkästchen Offlinedateien aktivieren auf der Registerkarte Offlinedateien aktiviert ist.
4.Wählen Sie die Option Vor dem Abmelden alle Offlinedateien synchronisieren aus, um eine vollständige Synchronisierung durchzuführen. Heben Sie die Auswahl dieser Option auf, um eine schnelle Synchronisierung durchzuführen.
Anmerkungen
·Doppelklicken Sie auf dem Desktop auf Arbeitsplatz, um den Arbeitsplatz zu öffnen.
·Bei einer vollständigen Snchronisierung wird sichergestellt, dass Ihnen die aktuellste Version aller Dateien im Netzwerk, die offline verfügbar gemacht wurden, zur Verfügung steht. Bei einer schnellen Synchronisierung wird sichergestellt, dass Ihnen eine vollständige Version aller Dateien zur Verfügung steht. Möglicherweise sind dies jedoch nicht die aktuellsten Versionen.
·Standardmäßig ist das Kontrollkästchen Offlinedateien aktivieren unter Windows 2000 Professional aktiviert, unter Windows 2000 Server jedoch deaktiviert.
·Auch wenn Ihr Computer zur Verwendung von Offlinedateien konfiguriert ist, müssen Sie die Dateien und Ordner im Netzwerk, die offline verfügbar gemacht werden sollen, auswählen.
·Klicken Sie in der Registerkarte Offlinedateien auf die Schaltfläche Dateien anzeigen, um eine Liste der offline verfügbaren Dateien im Netzwerk anzuzeigen.

Ich hoffe, dass es sich hierbei um die angesprochene Problematik dreht?

MfG

CJMeyer

#8 pingoin

pingoin

    Newbie

  • 5 Beiträge

 

Geschrieben 05. September 2003 - 07:42

@CJ Meyer

Danke für die Ausführliche Beschreibung. Ich werde das sofort ausprobieren und Dir berichten ob es funktioniert.

Gruß Pingoin

#9 Dschonny

Dschonny

    Member

  • 236 Beiträge

 

Geschrieben 07. September 2003 - 20:46

Ich habe hier das gleiche Problem mit zwei XP-SP1-Rechnern, der Netzwerkzugriff ist super-langsam. Wenn ich das mit dem 'Offline verfügbar machen' richtig verstanden habe, werden dabei doch die Daten des verbundenen Ordners temporär lokal gespeichert und bei bestehender Verbindung automatisch synchronisiert, oder? Dies wäre dann für mich keine Lösung, da sich auf einem der verbundenen Netzlaufwerke knapp 7GB an Daten befinden.
Der Zugriff auf das Netzlaufwerk war auch nicht immer so langsam, wenn ich mich recht erinnere, erst seitdem ich SP1 drauf habe..

Kennt noch jemand eine andere Lösung, um den Zugriff zu beschleunigen? Wäre für jeden Tipp dankbar.

Gruß,

Dschonny
Der Weg ist das Ziel.





Dieser Beitrag wurde schon 364527 mal editiert von Dschonny

#10 Lusthase

Lusthase

    Newbie

  • 7 Beiträge

 

Geschrieben 08. September 2003 - 07:50

"Offline verfügbar machen" ist hier Quatsch.

Es handelt sich bei dem Problem um einen bekannten Fehler im SP 1 der mit dem neueingeführten Signing beim SMB Protokoll zu tun hat um Man-in-theMiddle Attacken abzufangen.

Dafür gib es auf Anfrage bei MS einen Patch, der nicht einfach so zum Downloaden bereit steht. Dafür müßt ihr schon mit MS Kontakt aufnehmen.

Seht auch:

http://support.micro...b;en-us;Q810907

#11 Lusthase

Lusthase

    Newbie

  • 7 Beiträge

 

Geschrieben 08. September 2003 - 07:53

Ein weiteres Problem kann mit dem:

"Opportunistic Locking" von Dateien zu tun haben. Ein Prozeß hat die Datei gelockt ein anderer will darauf zu greifen und muss warten bis die Bestätigung für den Lock kommt. Das Problem habe ich, vermute ich, bei unserer Samba-Domäne.

Dazu:

http://support.micro...kb;EN-US;812937

#12 Dschonny

Dschonny

    Member

  • 236 Beiträge

 

Geschrieben 08. September 2003 - 15:35

hmm, danke für den Link erstmal, aber ich glaube nicht, daß der sich auf dieses Problem bezieht.

When you open a Microsoft Office file, it is opened as read-only. You must save the file locally to make changes.
You cannot copy files over the network, and network paths are not accepted by any network provider. For example, you may receive the following error message when you try to connect to an SMB share:

The file or the network path no longer exists.
You receive the following error message when you try to open a file on a network share:

Cannot open the file on network share. Make sure a disk is in the drive you specified.
Error messages similar to these may appear in the event log after you apply Group Policy objects (GPOs):


Nichts davon trifft auf mich zu, weder habe ich bewußt einen der Rechner auf SMB-Signing konfiguriert (wie kann ich denn checken, ob das evtl automatisch geschehen ist?) noch bekomme ich eine der angegebenen Fehlermeldungen oder habe keinen Zugriff auf die Netz-Ressourcen, es dauert einfach nur extrem lang.

Auch das es etwas mit dem Datei-Lock zu tun hat, glaube ich nicht, da keine anderen Prozesse/Anwendungen auf das entsprechende Verzeichnis zugreifen. Außerdem habe ich das Problem wie gesagt erst seit relativ kurzer Zeit und das SP1 war die einzige gravierende Änderung an dem System seitdem..

Hat sonst noch jemand ne Idee?
Der Weg ist das Ziel.





Dieser Beitrag wurde schon 364527 mal editiert von Dschonny

#13 pingoin

pingoin

    Newbie

  • 5 Beiträge

 

Geschrieben 09. September 2003 - 08:32

ich kann mich da nur Dschonny anschließen. Es ist einfach nur extrem langsam.
Wir haben im Selben Netzwerk, wie erwähnt, auch 98 Rechner, die sind wesentlich schneller.

Da wir auf ein Schnelles Netzwerk angewiesen sind, spielen wir schon mit dem Gedanken wieder auf 98 zurück zu kehren um die Geschwindigkeit zu garantieren. Dann wären zwar alle Annehmlichkeiten von Xp futsch, aber es scheint halt nicht anders zu gehen.

Oder hat doch jemand einen Idee?

#14 Dschonny

Dschonny

    Member

  • 236 Beiträge

 

Geschrieben 12. September 2003 - 22:51

..nach oben schieb...

weiß denn niemand eine Lösung für das Problem?
Ich habe inzwischen noch mein altes Win98-Laptop in das Netzwerk mit eingebunden und festgestellt, daß der Zugriff auf die Netzlaufwerke & Freigaben hier wesentlich schneller funktioniert. Hat nicht irgend jemand einen Tipp?

Gruß,

Dschonny
Der Weg ist das Ziel.





Dieser Beitrag wurde schon 364527 mal editiert von Dschonny

#15 nightmare197

nightmare197

    Newbie

  • 36 Beiträge

 

Geschrieben 19. September 2003 - 18:59

Was ist denn so langsam ? Daten übertragung ? oder die Herstellung der Verbindung ?

Habe div. Test mit Servern NT4.0 und W2k und WIN98SE Clients
Übertragen wird eine 200MB Datei. Hin und her.

NT4.0
ist am schnellsten mit 8MB/s.

W2K SP4
weniger schnell so um die 4MB/s.

Nun warum ist das so ?