Zum Inhalt wechseln


Foto

SQL Server 2005 LOG File verkleinern


  • Bitte melde dich an um zu Antworten
4 Antworten in diesem Thema

#1 uschcom

uschcom

    Newbie

  • 21 Beiträge

 

Geschrieben 29. November 2007 - 12:31

Hallo zusammen,

ich habe folgendes Problem:
ich habe einen SQL Server 2005 bei dem eine Datenbank ein 24 GB großes LOG Files bekommen hat.
Ich habe jetzt eine Sicherung des Transaktionsprotokolls durchgeführt mit der Option Truncate am Ende der Option.
Nach der Sicherung hat sich das Protokoll auf der Dateiebene nicht verkleinert. Ich habe daraughin mal eine manuele Verkelinerung angeworfen - auch ohne Ergebnis.
In den Eigenschaften der DB wächst das Transaktionsprotokoll um 10%. Diese Einstellung kann ich aber nicht ändern, zb. darf um 10% wachsen bis max. 1GB. Fehlermeldung sinngemäß: Protokoll schon größer als die gewünschte Beschränkung.

Welche Möglichkeit gibt es noch, die Datei kleiner zu bekommen, oder muss ich über TSQL Befehle gehen?

Vielen Dank für Eure UNterstützung....

#2 nobex

nobex

    Board Veteran

  • 2.023 Beiträge

 

Geschrieben 29. November 2007 - 12:44

Ich habe daraughin mal eine manuele Verkelinerung angeworfen - auch ohne Ergebnis.

Bekommst Du auch verfügbaren Speichplatz der Protokolldatei angezeigt? Welche Option hast Du bei 'Verkleinerungsaktion' gewählt?

#3 Noah

Noah

    Newbie

  • 16 Beiträge

 

Geschrieben 29. November 2007 - 15:38

Hallo, hatte mal das selbe Problem, nach dem Backup das Logfile shrinken und die Option "Releas unused space" wählen hat bei mir geholfen.
_______________________________________________

in wirklichkeit ist die realität ganz anders

#4 Balthazor

Balthazor

    Junior Member

  • 77 Beiträge

 

Geschrieben 29. November 2007 - 16:00

Hi,
Auf welches Recovery Model ist die Datenbank eingestellt (Full, Simple)?

Erstelle eine vollständige Sicherung der Datenbank.

Grüße,
Balthazor

#5 uschcom

uschcom

    Newbie

  • 21 Beiträge

 

Geschrieben 29. November 2007 - 16:04

Danke für die Tipps - in der Hektik natürlich wieder alle Optionen überlesen.
Beim manuellen Verkleinen der DB Option Daien wählen und dann Protokolle wählen, dann klappts auch.

Vielen Dank für die weiteren Tipps