Zum Inhalt wechseln


Foto

Exchange 2003 - Einstellung das keine Unzustellbarkeit gesendet wird


  • Bitte melde dich an um zu Antworten
52 Antworten in diesem Thema

#46 MikeKellner

MikeKellner

    Board Veteran

  • 756 Beiträge

 

Geschrieben 08. Mai 2007 - 06:10

Jetzt wird interessant. Ich schau im emanager log und stell fest dass die mail an die richtige Addresse von der IncomingPolicy verarbeitet wird, und die mail an die fiktive Adresse von der GlobalPolicy ?!? Die GlobalPolicy dürfte dort doch nichts machen? ich hab sogar versucht alle Filter in GlobalPolicy auf inaktiv zu setzen, das Resultat ist aber das gleiche.


Schau Dir mal die Route der Global Policy an.
Nicht die Filter sondern die Routen entscheiden welche Policy greift. Wenn du in den Routen also die Adresse annimmst und in der Policy alles deaktivierst, dann hat das nur zur Folge das die Mail ungefiltert an weitergeleitet wird.

Ist es sicher möglich mit dieser Methode mit IMSS, ein 550 nach dem "rcpt to:" zu bekommen ?

Kannst Du mal erklären was Du genau erreichen willst.
Erst willst Du alle durchlassen die sich vertippen und dann wieder nicht.
Gruß Mike

MCSE/TCSE

#47 SteveUnsen

SteveUnsen

    Newbie

  • 5 Beiträge

 

Geschrieben 08. Mai 2007 - 06:28

Danke für die schnelle Antwort

Schau Dir mal die Route der Global Policy an.
Nicht die Filter sondern die Routen entscheiden welche Policy greift. Wenn du in den Routen also die Adresse annimmst und in der Policy alles deaktivierst, dann hat das nur zur Folge das die Mail ungefiltert an weitergeleitet wird.


Ja wollte ich ja auch, nur hab in der Global Policy keine Route, "Route" und "Settings" sind hier grau, und nicht anwählbar.

Kannst Du mal erklären was Du genau erreichen willst.
Erst willst Du alle durchlassen die sich vertippen und dann wieder nicht.


Nein ich will niemanden durchlassen. Trend beschreibt wie man mails löscht die an Empfänger gehen die nicht existieren. Dies ist bei Spams ja sehr schön aber wenn jemand sich mal wirklich vertippt hat bei einer Adresse, bekommt er nie eine Benachrichtigung dass seine Mail nicht zugestellt wurde da diese einfach gelöscht wurde. Also möchte ich alle unbekannten Emails gleich am äußersten MTA (hier IMSS) nach dem "rcpt to:" ablehnen mit der entsprechenden SMTP Fehlermeldung.

Grüsse Steve

#48 MikeKellner

MikeKellner

    Board Veteran

  • 756 Beiträge

 

Geschrieben 08. Mai 2007 - 06:36

Sorry, klar da gibts keine Route. Teste mal bitte mit Telnet von außen eine Mail an die IMSS zuzustellen. Empfänger sollte eine Adresse sein die es nicht gibt. An welchem Punkt wird die Mail abgelehnt. Poste mal den Header des "non delivery Reports". Poste mal den Link zu den KB Eintrag.
Gruß Mike

MCSE/TCSE

#49 SteveUnsen

SteveUnsen

    Newbie

  • 5 Beiträge

 

Geschrieben 08. Mai 2007 - 07:00

Ich hab bis jetzt nur mit Telnet getestet, IMSS nimmt die Mail immer an, und leitet sie weiter.
Die Mail wird abgelehnt wenn mein Spamassassin, welcher nach dem IMSS geschaltet ist, sie dem internen Mailserver zustellen will, wo die Adresse ja nicht bekannt ist. Dieser schickt dann auch den "nondelivery report zu".

Link zum KB wurde hier schon gepostet.
Solution Details

#50 MikeKellner

MikeKellner

    Board Veteran

  • 756 Beiträge

 

Geschrieben 08. Mai 2007 - 07:21

Poste mal Deine Policys mit den entsprechenden Routen.
Gruß Mike

MCSE/TCSE

#51 SteveUnsen

SteveUnsen

    Newbie

  • 5 Beiträge

 

Geschrieben 08. Mai 2007 - 10:58

Ok, ich hab es am laufen.

Ich hab das Problem über Postfix mir relay_recipients und local_recipient gelöst. Ich hab da Dateien angelegt mit allen bekannten Emails, und jetzt funktioniert es.

Kann es sein dass die Lösung mit den Policies nur unter Windows funktioniert da IMSS dort ja anscheinend nicht mit Postfix funktioniert, sondern mit einer eigenen Mailengine.

Als Policies hab ich die Default Policies und als route hatte ich nur mein Domain mit From:* und To:mein.email@meindomain.com, die To: hab ich jetzt, nachdem ich Postfix geändert hab, wieder auf *@mydomain.com und *@*.mydomain.com umgeändert.

#52 MikeKellner

MikeKellner

    Board Veteran

  • 756 Beiträge

 

Geschrieben 08. Mai 2007 - 12:32

Eigentlich ist es so, dass die Konfiguration des Interfaces an den Postfix übergeben wird. Mir scheint, dass Deine Konfiguration nicht sauber ist und deshalb nicht funktioniert. So wie Du es gelöst hast funktioniert es zwar, ist eigentlich nicht gedacht. Geh doch mal mit Deinem Reseller die Settings durch.
Gruß Mike

MCSE/TCSE

#53 SteveUnsen

SteveUnsen

    Newbie

  • 5 Beiträge

 

Geschrieben 08. Mai 2007 - 12:54

Ja, mir ist aufgefallen dass alle Einstellungen die ich in der Postfix Gruppe im WebInterface mache an den Postfix rüber gehen (main.cf), von den routen in den Policies kann ich aber nichts finden.

Eigentlich sass ich die letzen 2 Tage mit einem Techniker von meinem Reseller vor der Kiste. Deren Trend Spezialist konnte uns auch nicht weiter helfen, der hatte auch nur die Lösung mit löschen der Mails parat.

Ich glaub ich belasse es jetzt dabei, da es etwas praktischer ist eine Datei zu bearbeiten als bei jeder Änderung im Webinterface eine Adressgruppe neu zu erstellen.

Nochmal danke für die Hilfe